Can't install Social Engineering DLC on MAC


#1

I’ve purchased the Social Engineering DLC but im having difficuly installing it on mac.

When I run the install program I get this error message:
[size=150]Lua error: config/run lua41: attempt to concatenate local ‘path’ (a boolean value)[/size]

Anyone else on a mac had this problem? How do I fix it?
(I dowloaded the original game through the app store)


#2

Same here, I also tried to install the update but it will not update from the app store version (v1.11) to the current one.

Fix coming???


#3

Are both of you trying to install the DLC to the MAS(Mac App Store) version of D3?.

It does look like there’s a small bug in the installer (just fixed it). However there are some other issues w/ the getting the DLC installed into the MAS build that the installer still can’t account for currently. Let me catch up w/ Cliff for another way to get this going.


#4

Well I am … nothing on the add-on says “Do not buy for Mac App Store version”


#5

It was an oversight on my part when I packaged it up. I should have a new build out in a day or two to fix things up.


#6

Ive had the same issue, bought the Mac App store version of D3, went to the D3 website and purchased the DLC only to get the same error (image should be attached)

Has there been a development towards this? love the game and would love to make it better with a working DLC!

Thanks!


#7

It’s been hectic… I know how I’m going to handle it… I just have to dedicate some time this week to code it up. … /me checks calendar … I’ve scheduled some time Monday to work on this… If for some reason I don’t get something out by tuesday… PM me with proof of purchase of the DLC and I’ll get you the raw DLC that’ll work with the Mac app store build of the game.


#8

Amazing, thanks for the update :slight_smile:


#9

Hi - just coming onto this thread re: Social Engineering…the game is great and I really want to play it to its full potential.

I bought Democracy 3 off the Mac App Store and was wondering if I can download Social Engineering from Steam?

Is there a preferred way of doing it?

Thanks!


#10

Hey Souldoubt, did Urkle sort out your problem?
Cheers!


#11

So, last week was a blur… a real blur. it’ll get done tomorrow or Monday, as Tuesday I’ll be heading off to GDC. (brain is mush tonight).


#12

Hello :slight_smile:
So, same problem here but since you said you’ll fix it, then I’m looking forward to that. Please keep us updated.


#13

I also have the same problem with the game I bought from Mac App Store id there any solution yet???


#14

it’s coming REAL soon… it’s all tested and will be updated next week.


#15

OK thank you very much for the quick reply. Looking forward to it !!!


#16

The final installers have been made, and I’m just waiting on cliff to put them on his website.


#17

I downloaded the 1.14 version from the Mac App Store but I still cannot install the Social engineering will there be another update for that?


#18

you need to download the updated DLC installer… The issue was purely in the DLC installer.


#19

Is it online because I go to BMT site but I keep downloading version 1.0 ?


#20

it should be this file with the md5… (use in a terminal md5 Democracy3-DLC…dmg)

MD5 (Democracy3-DLC1-1.01-2-Mac.dmg) = e1aee5b1f6f59f6d42aca1b2c1dc9c5f

I also emailed Cliff and asked him to verify that the new version of the installer has been uploaded to the store.