Failed to find race:..\src\SIM_Race.cpp 128


#1

Help i keep getting this error every time i try to start GSB


#2

same problem

tried redownloading the game (from the link the purchase email had) and reinstalling,tried reinstalling on clean,tried reinstalling after removing all registry keys etc (Revo Uninstaller), tried reinstalling on different path… im clueless,nothing seems to work


#3

Hi, is this a completely fresh new install of the game bought direct from positech that has not been patched since being installed?
The game writes error messages to \program files\gratuitous space battles\debugdata\errors.txt
If you are getting this problem can you email that file to me at cliff@positech.co.uk, and I can investigate.


#4

its not “fresh”

i installed the game,finished campaign,grinded challenges for few days straight with no sleep,then installed a mod (the starwars ships one) via generic mod enabler,finished that,disabled the mod,played normal GSB for a bit,and the next day this thingy showed up…
reinstall is not working so im just gonna go ahead and blame it on th devil plotting against my sanity

debug log is empty and error log just shows this line for each time it phailed:
26/12/2009 - 7::28 - Failed to find race:…\src\SIM_Race.cpp 128


#5

Ok, I strongly suspect that you have designed a ship using a mod, then deleted the mod files, but that ship still exists with a new (modded) race, and the game is not surprisingly trying to find a race that isn’t there any more. Is that it?
You can delete or back up all your ships from \mydocuments\my games\gratuitous space battles\ships


#6

i did,but it didnt help

i deleted all designs,deployments and orders and i still get the same error


#7

the issue has to be somewhere within the documents since i reinstalled the entire game…
i could probably just delete the whole thing but i`d like to know where is the issue exactly,because i have the feeling i will see it again sooner or later


#8

LOL nevermind

C:\Documents and Settings\Thunderbird\My Documents\My Games\GratuitousSpaceBattles\config.txt

the [race] setting had a “race = starwars” value so i just changed that to “alliance” and the game suddenly started OK

you should patch the game to change the race into one of the stock ones if the selected one is not found :smiley:


#9

Fine too but i’ll i have to redesign new ships got rid of them all


#10

i actually found that to be an advantage, my designs were cluttered by crap from earlier and i changed my tactics radically since then :stuck_out_tongue:
i also intentionally reset all my scenarios, now im trying them with Tribe ships

if anyone here plays EVE Online,he`ll get the joke:

REAL MEN HULL TANK!!!


#11

So…is there any way to fix this? I just installed this game as new, played a few missions required to play campaing and after conuqering 2nd planet a got this error I cant get rid of. Reinstall didnt help.


#12

face desk Silly Minmater your ships look like an explosion in a gridder factory. Make some REAL ships. from a shield hugging missile totting slug throwing Caldari hippie