[Fixed 1.10][Bug 1.09] "!Route Pending!:...\src\SIM_ResourceRoute.cpp 167/171" - Game Crash

Whenever I load any of my 3 saves (because they seem to get corrupted a lot) I now get the error message “!Route Pending!:…\src\SIM_ResourceRoute.cpp 167” I have no idea what this means or how to fix it (if possible to fix on my end) any help would be appreciated.

Here is the save file, it happens after roughly 10 seconds of play on slow speed (happens even faster on higher speeds)

This has happened 3 times now, this game is unplayable because I spend 2 hours or 30 minutes or 5 hours to make a factory and out of no where I get this dam error and all of a sudden all my save files wont load. And no re downloading the game doesn’t work.

i have a Cash after i Build a Large Factory. And Some Items have no/failed Textures.

Here are my Savegame and Screenshots:

Best Regards

I think this is caused by 1.05 (I didn’t see it happen in 1.04). Soon after loading the game crashes with the following:

I’m getting this as well.

I fixed this by removing some possible paths from resource importer to equipment.

I’ve just started getting a new error though:

i also have frequent crash after a while in a game. It’s always the same error.

7/2/2017 - 2::1 - Begin Scene 7/2/2017 - 2::6 - D3DERR_INVALIDCALL 7/2/2017 - 2::6 - Begin Scene 7/2/2017 - 2::11 - D3DERR_INVALIDCALL 7/2/2017 - 2::11 - Begin Scene 7/2/2017 - 2::11 - D3DERR_INVALIDCALL 7/2/2017 - 2::11 - End Scene 7/2/2017 - 2::16 - D3DERR_INVALIDCALL 7/2/2017 - 2::16 - Begin Scene 7/2/2017 - 2::16 - !Route Pending!:..\src\SIM_ResourceRoute.cpp 167 7/2/2017 - 2::16 - !Route Pending!:..\src\SIM_ResourceRoute.cpp 167 7/2/2017 - 2::16 - !Route Pending!:..\src\SIM_ResourceRoute.cpp 167

I reload my game and after a few seconds it crash again.
i don’t care really care… this game is awsome and i start again.
I also have a high performance computer.
i5-6600k gtx/980TI 32gb ram windows 10 and M.2 drive.

i’ll attach my actual save game.
savegame 8 or autosave ( both crash after few secs. )
thanks and keep the good job.
savegames.7z (972 KB)

well in the imagine you can see


I tried to stress-test a custom made map for a mega factory I wanted to build and found out that the game instantly crashes when there are more than 40 resource importers.

The ERROR popup says:

!Route Pending!:..\src\SIM_ResourceRoute.cpp 167

40 are okay, but once you place down the 41st Importer the game crashes, probably because of reaching the hard-cap.

Probably nobody tried to do something that ridiculous yet :smiley:

No…a few people have! its a known bug, fix in next build:

  1. Fixed the ‘Route Pending!’ bug.

Ahhh… good. Somehow I’m glad that I’m not the only one with that problem… almost thought I did something abusive to the game and that’s how the game was going to pay me back. :smiley:

Good that it is fixed… I’m actually having problems to work around that issue… rendered some versions of my savegames unloadable.

Also probably should have looked into the Current fixes thread… Next time I’ll look there first to avoid posting an issue that’s fixed with the next version.

Sadly, I have to report that the route pending bug ist still present.

gigafactory.rar (248 KB)
mission_giga.txt (1.37 KB)

Is this with a new game,. or a game from a previous build?

This is an old savegame.
Are you saying that I cannot use my old savegames anymore? :frowning:

When i connect another recource importer to my factory the game crashes ore when i kick it off again, attached are my save file and a screen shot of the crash. i’m running versions 1.07
save.zip (1.68 MB)

As others may have pointed out… the Route Pending Bug is still present in 1.07

I ran my Factory for a day in 1.07 without any problems whatsoever… so I thought the Route Pending Bug is solved… but nope… all my Save games are busted once more and the game crashes shortly after loading any of them. (Yeah I make occasional additonal snapshots so I can revert, but this time it seems like ALL of them are wrecked)

(You can load it and pause it to have look around the factory, but if you run it for a few more seconds it crashes with the resource pending error)

My factory is using a custom map I fiddled together in the text editor instead of the ingame editor which is too buggy… so it’s quite huge (producing 512 different car design variants)… although not much larger than a medium map.

Maybe I hit some cap again with the amount of resources being imported and I didn’t notice until I tried to reload a previous snapshot.

Guess I’ll leave such monstrous factories alone for the meantime… they are way too unstable to maintain. A small change and the game crashes or goes haywire.
autosave.zip (771 KB)

Hi, there is a limit, but the reason its being reached is probably related to me not clearing some stuff I should be clearing when quitting to the main menu and loading another game. Until my fix is checked in, its worth always quitting the app and restarting it to load a really really big game just for now.

Well I never go to the main menu from within a map… I always kill the game by clicking on the X and then restart the game… because it’s faster that way… xD

But maybe I went to the main menu in between somewhen but I can’t remember for sure. I only know that at least 90% of the time I close the game the hard way (or because it crashes).

Are the savegames lost…?

If so I’m not really angry anyways… the game is in early Alpha… That’s what I expect to happen… that’s what I signed up for. Did so with Prison Architect and Factorio as well… so yeah I’m that kind of masochist. :smiley:

Looks like my dream of 1 car per second will have to wait a while longer.

I’ve got another fairly large factory which is hitting the !Route Pending!:…\src\SIM_ResourceRoute.cpp 167 asserts again (I was originally seeing them only on level load as per here: http://positech.co.uk/forums/phpBB3/viewtopic.php?f=53&t=17933&p=83333&hilit=167#p83333).

Steps to repro: Found it when I was building the ‘Make Tire’ slots towards the top of the map.
-Build two additional Make Tire slots.
-Note: it happens even if you build one, delete a previously build tire slot, build a second tire slot, maybe there is a leak there?[/list]

Interestingly I ran into this assert much earlier in the game as wellwhen I had a previous factory running while building the current factory (I went Initial factory -> specialized slot factory with 1 car/5 seconds -> current 1 car/second factory). Deleting the seed factory solved the problem for quite a while. As I recall I had only just started working on the Fit Body section of the big factory when that occurred.


p.s. Do you have any plans to setup a more formal bug reporting/tracking sub-forum or system? Took a while to figure out if this was a known issue or not. I get the feeling that this is simply running out of resource objects again.
f6o.zip (853 KB)

I have gotten this tonight working on a large map tinkered and what not. always getting the message when i try and add the 32nd resource import.

Tried the same map new start and installed all 70+ imports without issue.

Map was the 100x100 from the mods folder.
I can upload a save is needed.