Game Does Not Work For Even A Second

Hi. I’ve posted a request for help before and been ignored. I now have some data that might prompt someone to help me out this time. Could someone please help me make this game work? My son bought it as a present having saved up for it and I don’t think it’s fair that the demo works but when we try to start the game it doesn’t even make it to the title screen without crashing.

What does happen is that it says that the game has encountered an error and offers to send off an error report. I have managed to track down the text file that it send with the error report, which says the following:

<?xml version="1.0" encoding="UTF-16"?>

Can anyone please help me with fixing this? I have tried looking for the debug file that I have seen mentioned in other posts but it does not seem to be there.

Aww now hang on a sec mate, that is not quite true, You did get a response to your previous post. Please keep in mind that a majority of the support is conducted by active members of the forum and unfortunately, we don’t have many of them left.

But that is beside the point. If you would like, I will try and help you as best as I possibly can.

Now I have had a look though that error report but I can not work out much of what it is saying. So lets start at the beginning.

Could you please let me know.

  • Where did you purchase the game (Steam / GoG / Positech)
  • What is your current OS
  • Has the game created a directory \My Documents\My Games\GratuitousSpaceBattles

Suggestions at this point in time:
Re-Download the game from where ever you purchased it from and re-install. This will make sure you have the latest updates.
Ensure that you have appropriate permissions for the game and that it can access the internet.

When I said that I received no replies I was referring to my first post: viewtopic.php?f=21&t=8277&p=62985#p62985

If I remember correctly (as I bought the game in June) I purchased it through the main website, which directed me through a company called My OS is Windows XP. The game has indeed created the GratuitousSpaceBattles folder.

I’ve tried uninstalling and reinstalling it loads of times before I eventually gave up.

How do you mean by permissions for the game? Could you please explain how I do this?

I suspect that the answer may be connected to the fact that there does not appear to be a debug file. I have often read people referring to it in this forum but it does not appear to be among the files in the GSB folder. Of course, this may be due to the game never being able to start as this file may be created upon the first full startup or the first time it crashes after startup.

Yes, you are quite correct. The lack of a debug file indicates that the game is not even launching.
Therefore there is something on your computer blocking the launch. (I also run win XP)

Ok, let us try this:

  1. Download the latest version from your humble bundle. (let us ensure that you have the latest patched version)
  2. Uninstall the game. Ensure that the folder \GratuitousSpaceBattles\ in My Documents has been deleted
  3. Ensure that your video drivers are up to date.
  4. Reinstall the game as administrator (this will ensure that the permissions are correct)
  5. TEMPORARILY Disable any virus software and anything else you might suspect that may stop the game running
  6. run the game

Hopefully we should have the game running, at the worst an error report we can use.