[Locked][Bug 1.13] Map Editor Crashes, Bugs and Problems


#1

I’ve just noticed that when i updated to 1.02 that i didn’t get my factory exactly as i left it in 1.01. Since i used a modified map (mainly using a no rent space and adding several resource imports), i noticed that :

  • when a export or import slot is unused, the space is replaced by the game map value.

  • the rent value of a sector is replaced by the current map one.

  • when there was nothing on the customized map on import or export wall there is now what is defined on the map, looks like they’re somewhat merged.

-> It seems that the game doesn’t save everything at the moment, relying on the defined game map values in order the initialize the game.

thinking about it it’s the case since the 1.00 alpha version.


#2

The editor is very much a work in progress. if you are using it to edit the current save games, then yes, the new installer will overwrite them. You should be able to edit and save out new missions by editing a bunch of names and numbers, but when I make a pass on the editor to truly create new missions easily, all of that will be handled.


#3

I was messing around with the map editor and when I closed the game and came back it gives me this error.
gyazo.com/7fcb31f3793f18fc3cc1a3458314c2e8


#4

This is a problem which exists since the first alpha of the game, as the map editor is very buggy and unfinished. Cliffski knows about it and i’ve read he plans to make something better in the future, but fixing the current bugs in supplies and gameplay looks to be the priority.

The only way i’ve found to fix the problem is to reinstall the game.

Should i do changes on a map, i’m very careful, with only making changes to import and export slots and rental price. I don’t add nor change the rooms sizes as i can completely crash the game.


#5

I started out to create a custom factory map on the Mega slot, but I have encountered a number of bugs when doing so:

  • When erasing import/export slots with rt click, some on the very edges would not disappear.

  • Wall types could be chosen, but the UI was layering incorrectly.

  • The floor type menu was empty, (no entries)

  • Spaces can only be created dragging from top left to bottom right.

  • Zero-size spaces were still registered on the text file. (I could not find a way to delete them within the in-game editor).

  • Using Backspace to delete the Price of footage ALSO deleted the name of the room at the same time.

  • Del does not delete text, only Backspace works

I tried a couple of configurations: 1. building all the way to the edge, 2. leaving a 1 tile gap from the edge. I made sure to put export/import slot ONLY against walls. However, every time I tried to start the map the game crashed.

Because of no floor options, I went into the text file and copied floor options from the other scenarios. Still, it crashed the game.

End result: I was unable to create a custom map with my own “rooms”-- each and every attempt crashed the game when I went to “Start Game”. Please find files attached.

mission_mega.txt – Initial creation, built up to the edges
mission_mega (2).txt – Last attempt with 1-tile border around the entire factory, floor and wall types manually inserted into the text file.
mission_mega.txt (2.97 KB)
mission_mega (2).txt (3.09 KB)


#6

Hello I have just downloaded the game this morning and I found my self in the building zone editor.

  1. There is no way to go back to the main menu from this function. Please add a button for that.
  2. Because of this I had to close the game to get out of it and now when I go back in to restart I get this error pop up.

ERROR
Unknown Building Zone Type:…\sro\Sim_Mission.cpp235

Thank you,
Andrew Moore


#7

Hi the level editor is very buggy and has not been addressed since our initial release, but is left enabled because some people wanted to experiment. I’d suggest a re-install and to backup all the missions if you want to try using the editor for now.


#8

Hello, I just recently purchased the game, got in and everything. I went to go start a new game, and right when I hit the button I received and error. “Unknown Building Zone Type:…\src\SIM_Mission.cpp 235” The game immediately closed, and refuses to launch a new game.


#9

Did you try the level editor? its very error-prone right now, so don’t do that yet. I’ll fix it soon! In the meantime just reinstall and all will be fine.


#10

Alright, thank you!


#11

The fix I found is to search for the map you were editing, delete it, and run the installer again. Your loose what ever edits you made, but… then again… it doesn’t work anyway, so not too big of a deal


#12

Thank you sir,

I originally did not want to go into the editor so I would suggest an exit button update and I will re-install.

thank you,
Andrew Moore


#13

Sorry to hijack this thread but it seemed an appropriate place to mention another nasty bug which I spotted when taking a quick glance at the editor yesterday, on my first play.

I loaded in the gigantic map and had a click around, without really noticing what i was doing. It seems that I toggled off all 5 of the marked areas, which I assume are areas you have active at the start, or can expand into later on. Anyway, I clicked save to leave the level, with nothing highlighted, and trying to load that map into the game crashed it every time.

What was worse was that every time I tried to reload PL then it would crash again, as if it was checking this map and losing the plot because there was no area on the map active to start from. I may be misinterpreting what was going on but it’s probably worth checking the save level condition to ensure someone isn’t trying to save a broken map.

As a side-note the only way I could go back and play again was reinstalling the game completely. This was on the 1.06 version, however, so apologies if this has since been fixed.


#14

Hi,
I didn’t check if it has been reported.

When i edit, almost always, I get an error 255. Then the game crashes and won’t restart. All i can do is remove program and reinstall.

Taz


#15

Hey Taz,

maybe you want to take a look into this thread:
http://positech.co.uk/forums/phpBB3/viewtopic.php?f=57&t=17668&p=82653&hilit=map#p82653

So reinstall (no need to uninstall first) the game to get it working again …


#16

No, that is not the problem, there really are bugs.
You can create non function maps by placing export and import terminals outside the walls. This will be saved, but as soon as you try to load the map (or even boot the game) the program will crash. Another problem lies with the ‘ground tiles’ for new rooms these can not be set in the editor. You can fix this all in the map files which can find in the data map of the game directory.


#17

Yeah, there are a lot of bugs related to the map editor… I suggest you avoid it currently until it gets fundamentally reworked and fixed.

So either play with the stock maps… or try downloading one of those made by some players over there:

New Maps

… or if you are very brave you can try and create your own custom mission file through a text editor by looking how the other maps work which are located in the “C:\Program Files\Production Line\ data\missions” folder, or wherever you have installed the game.

It’s actually not that hard to manually create your own mission file once you get into the structure.

… I merged various topics on the map editor issues together now …


#18

Just hit this bug on 1.10. I started a brand new map, played for a few minutes, it crashed, then had this error showing up. I didn’t use the map editor.


#19

As a side note… when you didn’t use the map editor… why do you post your crash report into the bug thread that is specific to bugs that happen while using the map editor? :stuck_out_tongue:

Anyways… more information about the bug would be nice… like a save game that can be found under “\Documents\My Games\productionline\savegames” or even the error logs that can be found under “\Documents\My Games\productionline\debug”


#20

Playing with the map editor, got this error after crashing the game twice. Maybe I made too many changes to the map?

I cannot start a new game anymore, or load a save- the same error will pop up. *Looks like I will have to reinstall. This bug kills your game.

as MeduSalem pointed out, just delete the mission that causes the crash and you can play again, it reverts to the default map. However, some saves still will crash your game.

Checking the error.txt file looks like a texture cache issue.

17/2/2017 - 20::32 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 18/2/2017 - 22::26 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 18/2/2017 - 22::29 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 19/2/2017 - 4::50 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 19/2/2017 - 18::17 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 19/2/2017 - 18::17 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 19/2/2017 - 19::27 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 19/2/2017 - 22::23 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 15::47 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::25 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::30 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::37 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::40 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::40 - Unknown Building Zone Type:..\src\SIM_Mission.cpp 235 22/2/2017 - 16::42 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::42 - Unknown Building Zone Type:..\src\SIM_Mission.cpp 235 22/2/2017 - 16::43 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::43 - Unknown Building Zone Type:..\src\SIM_Mission.cpp 235 22/2/2017 - 16::45 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::45 - Unknown Building Zone Type:..\src\SIM_Mission.cpp 235 22/2/2017 - 16::46 - Assertion failure:filename:..\src\GUI_TextureCache.cpp,linenum:25 22/2/2017 - 16::46 - Unknown Building Zone Type:..\src\SIM_Mission.cpp 235