Missing module after clean reinstall and 1.62 patch


#1

I’m recovering from a hard drive failure and reinstalling GSB. I’ve got all the expansions, and started my reinstall by installing GSB, the race expansions, and the campaign expansion. I started GSB, entered my reg code, closed the game, and restarted in order download and install the 1.62 patch. The game went to a white screen and crashed with the following error (shown here twice because I tried again to load the game):

I’ve uninstalled everything, deleted the C:\Program Files (x86)\ GSB folder and the …\My Documents\My Games\GSB folder (no, I know those aren’t the precise locations–I’m short-handing), but I still have the same problem. I have mods downloaded, but not installed yet, so I know that’s not the issue–this is a clean, Positech-files-only install, but it doesn’t seem to want to function. Do I need to install in a particular order, install and patch in a particular order (i.e., GSB, patch, campaign, races), or do something totally different?

Any help would be appreciated, because I really need to jump back into campaign mode and grind my foes into gratuitous space dust.


#2

G’Day Captain Sardonic
(Sorry to hear about your hard drive failing)
As far as I can tell, what you have done should have worked.

Based on the error, you are missing a module. Have a look through your installation and look for the:
\Gratuitous Space Battles\data\modules\frigate_automated point_defence.txt module.
If the module is not there, re-download the install file and try again.


#3

The module quoted - “frigate_auto_pointdefence” - is the name variable for the Automated Point Defense System (module filename: frigate automated_point_defence.txt) found at C:\Program Files (x86)\Gratuitous Space Battles\data\modules on my machine. You might try a) making sure that file is present, and/or b) move the file elsewhere and see if GSB will run without it in place.


#4

First off, thanks to both of you for your input. Here’s the latest update…

I uninstalled everything, deleted the relevant folders, and started over. The install proceeded in the following order:

GSB (input reg code), exit GSB, reload GSB in order to auto-patch.
Patch didn’t load, but I had most of the patches from 1.25 through 1.62 in a folder on another PC, so I installed 1.57 (in order to accomodate installing Galactic Conquest since GC came out with the 1.56 patch).
Install Galactic Conquest, reload to auto-patch, auto-patch fails.
Install races in the following order (reloading after each install; auto-patch never ran): Tribe, Swarm, Order, Nomads, Parasites, Outcasts

I got a white background screen after installing GC (running in full-screen 1920x1080 and windowed 1280x800), but the game otherwise loaded fine. After installing Outcasts from the brand-new installer I re-downloaded from BMT Micro, I got the same Module Type error as before. Which is particularly strange, as I’d been running with all the patches and expansions with no errors before the reinstall process.

Is it possible this is just a corrupt Outcasts installer, or might there be a deeper issue?


#5

What version are you currently running at ?
(Try changing the date on your pc by one day to force GSB to look for an update - there may be another solution but i cant remember at this point in time)

But yeah, it might be worth re-downloading the Outcasts


#6

Running 1.62 currently, which worked just fine until I installed Outcasts. I even pulled in a new DL of Outcasts from a different BMT download link and it’s continuing to give that same error about the frigate point defense. And I ran the latest installations as a Windows 7 administrator and with my anti-virus software temporarily disabled.

This is particularly strange because I had 1.62 and all the expansions (plus several mods) on my laptop and it all worked with no hitches. Now? Not so much.


#7

I thought I’d fixed the problem by editing the .txt file for the frigate PD cannon to show the proper name, but now I’m getting the following error upon trying to launch the first tutorial mission following the initial deployment:

I know part of the problem had been that Windows 7 had done its foolish “set all files to read-only” thing, but I’ve since undone that. I really don’t want to have to chase through all the text files and such in search of a solution, nor do I want to uninstall and reinstall all of GSB for the eighth or ninth time.

Any other thoughts on what might be wrong?


#8

Sorry mate, If Windows 7 has placed a read only over your install then it may be a case that any updates might not have worked.
(Another forum member had a similar issue awhile back, it was messing with the game running correctly)

To be 100% sure that it will work, my suggestion is to wipe the GSB install, then start the reinstall process. However, once you start - make sure that the files are not set to read only before you proceed with the DLC updates and patches.

Once you have finished the update / installation, ensure that win7 has not placed that read only flag on any of the files.


#9

As far as I can recall from what Cliff said about this, these type of errors indicate some shader or similar effect that your computer has failed to handle. They should not cause the game to actually crash or stop running (my errors file is full of them). Just something to consider as you work toward a solution; a bunch of these errors are not anything to get too worked up about. :slight_smile:


#10

Actually, I was less concerned about the D3DX error than I was about the fact that the missing explosion effect kept causing a crash. However, I wiped everything out (again) and reinstalled from the ground up, starting with the DLC and then installing every patch I had from 1.25 to 1.62 individually along the way. Something worked, because I’ve had GSB up and running for about an hour and a half with no crashes so far. I’ve yet to try the campaign or any mods yet, but at least the vanilla game + DLC is back up and running.

The one thing I could think of to make this easier would be if Cliff made an “all-inclusive” patch (assuming they aren’t already) to get a user up to date, rather than having to go through the tedium of installing each patch separately. But it may not be necessary, as the problem could just be related to a quirk of my PC.

In any case, thanks again to you and darkstar for the help. I’m not sure what was wrong, but I’m fairly certain y’all helped point me in the right direction to get it fixed.