No weapon sounds


#1

I installed the game today, and found out that the weapon sounds do not appear to be working. Normal sounds do work(music, ambient). I verified that the sounds actually do exist and are not corrupted.

One thing I noticed is that the game is making 512 sound channels. I have no idea if this could be the conflicting bit.

I am running windows 7 64 bits. With a ATI radeon HD 4850X2, Creative SoundBlaster Audigy SE. A Intel E7400 2.8 GHZ 2 cores and 2 GB of RAM. Everything else appears to be working and the game doesnt throw any errors. It does appear to think its on vista though…

----DEBUG FILE----
Windows Vista detected
GSB Debug File. App version Full 1.32
Desktop resolution is 1920 x 1200
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine
releasing D3D engine
D3D released
END DEBUG—


#2

there is an option to turn sounds off on the options screen, whilst keeping music on, so its worth checking there. Is it possible that you are just zoomed out and not close enoguh to hear them? There are also options to toggle off sound hardware acceleration and pitch shifting, which you might try fiddling with.
If you have a siound card that has any kind of fancy acceleration features or effects that it turns on by default, I’d turn them all off. That stuff always causes conflicts with stuff. I wish sound card makers would just write drivers that work, rather than thinking ‘ooh we can code our own echo effect and have it on by default’.
Anyway, enough of my ranting…


#3

I did mess around with those settings, I will double check it. And about the sound drivers, yes, that pisses me off to. Because of that my cockpits in IL-2 sound like im in a shower…

Just tested it. Sounds are working now. I turned off hardware accelerated sounds and pitch shift. Although I tried that yesterday and then it didnt have any effect. I must have screwed up something!


#4

Same issue here, i only have sounds when i’m EXTREMELY zoomed in at max and only in certain areas, moving the map a bit can mean the difference from ‘i don’t hear anything’ to ‘OH GOD TURN THE VOLUME DOWN!’. Otherwise they are heard very vague, barely audible, like the battle is taking place far away and i faintly hear the booms (like i’m underwater if that helps ;p). Also i have tried turning on and off pitch and hardware acc.

LE: Also, sometimes the interface button sounds go dark aswell. And i noticed that with pitch on and hardware off, sometimes, rarely, i get weapon sounds. I think it’s something to do with the channels. Can we set them default to 128 somewhere in an .ini?


#5

You can. As I recall its prefs.ini in \my documents\my games\gratuitous space battles


#6

Tried fiddling around with the value but pretty much the same. >.>


#7

is this on a low spec machine? it could be a cpu failure to process everything, although that is unlikely.