Sound issues, sounds cutting out and staticy


#1

I’ve done some google and forum searches and haven’t found any issues like this, so hopefully someone can help. In battle, I have all the sounds: gunfire, lasers, shields, engines, hum, etc, but with explosions, and often with kinetic weapons, the sounds will start and then immediatly cut out and make a static type popping noise. This makes the heat of battle with my fighters swarming sound all clicky and poppy. Sometimes a majority of the sounds won’t play at all and then they’ll pop in a little distorted and then back out. It’s very similar to the other problem on this forum that the guy with the soundblaster had w/ windows 7, but what worked for him didn’t for me.

stats:
windows xp64bit
soundblaster audigy 2 zs platinum w/ latest drivers.
headphone setup
hardware acceleration is on (but still had the same problem putting it down a notch

what i’ve tried:
messing with the zoom level, maybe the volume fluxes in zooming messed with it? nope.
switching on/off hardware sound and/or pitch shifting. nope.
updating drivers. nope.
messing with speaker settings, i.e. turning off the rear channels etc. nope.
messed with readily apparent sound setting via creative audio console and windows control panel sound devices settings. nope

no clue what to do 'cept get a new sound card now, and since I haven’t found anything about this problem on google, this is my last bastion.

Help me Obi-wan Cliffski, you’re my only hope.


#2

if you look in the \my documents\my games\gratuitous space battles\config.txt (or might be prefs.ini or something like that) there is a setting for sound channels, set to 512. You can try reducing that number and seeing if that helps?


#3

Thanks for the reply! but alas, it seems my problem runs deeper. Looking around my device manager i noticed my video card and sound card are sharing the same IRQ (which probably accounts for EAX not working in some games and directsound not initializing when i tried the kx drivers). My motherboard is too small, so i don’t have an extra slot to move the card to, and with my copy of xp64, it looks like i can’t change the computer out of ACPI mode to manually assign IRQ slots, though the idea of disabling all power management to get rid of some pops and clicks just so I can hear my fighters blast frigates out of the sky seems a bit dodgy, if quite gratuitous. Looks like I may be stuck with the problem unless I get a new motherboard, or maybe windows 7 has better support for IRQ assignments. If anyone has any workarounds or advice, it’d be much appreciated, but as the problem is now beyond the scope of the game it’s not really expected.

Good to see a dev getting into the support forums himself and helping people out though, thanks a bunch :slight_smile: