[Outdated][Bug 1.37] Failed to Open Save Game File Crash


#1

Apologies if this has been reported before. I’ve tried to have a search and not found anything as yet. This is the first report I’ve made so if I’ve missed something then let me know.

The error seems to span every save game I have and has been happening from version 1.35 - 1.37 (only got the game recently so can’t say for previous versions). The game will be playing fine and then next thing I know freeze and the error message appears as shown in the screen shot. I’ve tried various save games (mainly because I keep failing!) and it’s happened on every one. Not as yet managed to find a pattern of when I happens as it seems to be completely random. Once you click OK the game closes and you have to re-open to the last save or auto-save which is a little frustrating.

I’ve included an archive with the Debug files and an archive with the latest save game, I’ve not included more than the one save as it seems to be universal across the different saves so I don’t think that’s going to be the issue.


debug.zip (1.96 KB)
savegames.zip (139 KB)


#2

Hi, I just looked into this. That save game you attached seems to load and run fine for me. It sounds like the game is crashing when it autosaves, some times. Is it possible that there is some file-system related software that could be preventing the game writing to the disk?
Have you got a ‘redirected’ my-documents folder? (maybe on an external hard drive or on a network drive)

This error message comes from the very, very start of the game trying to save the game to disk, just when it picks the filename, and goes to open the file. It could be that the file itself is locked, or open (maybe left open in the preview window of windows explorer? it could be held open by an over-aggressive or buggy antivirus program.

This is all guesswork, and none of the above should cause a crash TBH just thinking out loud :frowning:


#3

I don’t generally have anything running at the same time as a game so can’t see it being the file open. Plus it will autos average perfectly fine and then randomly not work.

I’m only using Windows Defender at the minute as anti-virus as the majority of the other software I’ve used has slowed my PC to a crawl or just straight up missed things.

The My Documents folder isn’t on a separate drive on the Laptop I’ve been playing on. If it was my PC maybe that would have explained it as it’s on a secondary internal drive but not with my laptop.

Not sure what it is then.


#4

I’ve been into settings/options and removed the auto-save option and I’ve not had an issue since. I do however seem to get the same error occasionally if I try to overwrite an existing Save Game. I’m definitely going to blame my Laptop now as I think there must be something holding the files… What though I haven’t a clue.