Patch v1.12 for Stardock Impulse?


#1

I just bought the game a couple days ago using Stardock Impulse. So far it’s pretty good. I didn’t know if there suppose to be sound in the game or not, I just get music and no sound effects. Will there be a patch available to fix the Impulse version?


#2

I’m an impulse user myself, and have the same issue, but I doubt the sound issue is linked to the impulse version.
I don’t know if there even is a specific impulse version; Impulse generally just installs the game, but is not required to actually play the game.
When you zoom in close to the action, you should get sound fx. (there are already posts about this sound issue, so you’re not the only one with this problem.)

I can also say that:

  • Impulse is generally a few days to a week behind with the patches.
  • When patching, remember to check the install directory (impulse installs it under a different dir)
  • It’s no problem to let the game autopatch outside impulse, and then letting impulse patch again when they’ve caught up with the new release. (well, I autopatched from 1.10 to 1.11, and let impulse do the 1.10 to 1.11 patch a few days later (last thursday I think) when prompted, and didn’t notice any problems. Now I autopatched to 1.12, and impulse still says I’m 1.11. I foresee no problems when I let impulse patch to 1.12).

I could be wrong about this of course, I’m just saying what my experience as a casual user is.


#3

No you are right, you dont need to wait for impulse,. just put your serial code in on the on-line screen, and pick a username, and next time you start the game it will check for a patch and download/run it.


#4

Oh so that’s what that was when I had to go into task manager and kill the process. I don’t know if that’s what it was doing but I had already enter my serial code / username and restarted the game the title logo popped up and a little blue progress bar started, however when it finished it just sat there doing nothing, for about 10 minutes. I had to end the task because apparently it locked up or froze. It still says v1.11 if that was suppose to update to v1.12

I also noticed what is the purpose of the ‘Online’ option other than entering your serial and username? Is there suppose to be multiplayer, because if there is I don’t see it.
Hmm, I looked in challenges and found it, would have assumed ‘online’ meant multiplayer, I guess I was mistaken.


#5

What happens to me after the blue bar is full (working as it’s intended I suppose):

  • automatic exit of GSB (without waiting 10 minutes; maybe 10 seconds at most)
  • automatic install wizard for patch (“browse” for correct game directory here for impulse users. )
  • let patch run
  • restart GSB
  • Win
  • get bothered by impulse a few days later about the above patch. Let impulse do its thing and patch the game (or re-check if the installed version is up to date) to update the version number within impulse.

I think your game just locked up at the “exit game and start patch” bit.
There is a “patch” folder somewhere in the game directory, where downloaded patches are stored.
You can try re-patching from there, and hope the program lockup doesn’t repeat in future patches.


#6

I set the online stuff up, restarted the game, got something about installing 1.12. Clicked through the dialog boxes and it encountered some kind of error while installing about a missing file and closed. Now I can’t get it to attempt to update again and seem to be stuck at 1.11. Even tried uninstalling and reinstalling the game via Impulse.

Edit: I don’t have a “patch” folder in my GSB directory.


#7

I had that the first time, that’s what happens when it doesn’t patch into the correct install directory.
The patcher defaults to “program files/GSB beta”, while impulse installs it to “program files/positech/GSB”, so you must direct the patch to that folder.
It’s the positech folder that should have the downloaded patches, not the beta folder (impulse users can delete the beta folder after an incorrectly pathed patch).
If it isn’t there, maybe let impulse do a “verify installation” (I think its different from a reinstall), and hope the in-game patcher kicks in, and runs without fault this time.


#8

Heh, now I really broke it and GSB isn’t showing up in Impulse at all.

Edit: I had to go under Impulse settings and turn on “Show hidden applications”. Shows up fine now.

Edit 2: Still can’t seem to get it to patch again. Tried deleting the Program File\GSB Beta folder and I don’t seem to have a patch folder anywhere.


#9

How do you let the game autopatch outside of Impulse? I just uninstalled and re-installed (through Impulse). And what do I do with this directory that Impulse picks?

It seems to me that what’s needed is a “look for updates” button. Anyways, can someone help me out?

Thanks,

Evilmeat

Edit: I just found that Stardock acknowledges that there’s been an update, and even has an update option, but this doesn’t really seem to do anything.


#10

The issue with stardock and positech patches is explained and fixed here:

viewtopic.php?f=21&t=3113&p=16234&hilit=installer#p16234