Problems with Mods


#1

Howdy All-

I have Win 7/64 and got GSB from Steam, if that makes any difference.

Anyway, today I decided to get some mods. This has broken my game in some sort of way and I’m hoping folks here can tell me how to fix it (short of a re-install). And if I do have to re-install, is there any way to save my progress? Thanks in advance.

Here’s the deal…

I have installed Archduke Astro’s Classic Dreadnoughts, DarkStar’s Unity, and GATC’s Xedilco. I installed them all without running the game in between. Unity seems to work fine. I can fight battles, unlock stuff, and select the Uni-T races to play. Same with Xedilco. However, I have the following problems, and I don’t know what mods caused them (other than the obvious)

  1. Dreadnougths Don’t Work
    It’s like they’re not installed at all. There is no trace of them in the game.

  2. I cannot use the ship designer from the main menu. While the ship designer will start OK and display some random saved design, the game crashes to desktop as soon as I click on the CHANGE button to select a different hull. Despite all this, the ship designer works just fin from within the deployment screen of a battle. It’s just from the main menu that kills it.

  3. In an effort to try to solve the above problem, I tried uninstalling Dreadnoughts. That proved no problem–the game didn’t notice their arrival so didn’t mind their departure. Then I tried to uninstall Xedilco. There is no README for this mod so I just followed the instructions for uninstalling Unity, hoping Xedilco worked the same way. This involved:

1: Deleting any ships I’ve designed using Xedilco parts. No problem there, haven’t made any yet.
2. Delete xedilco.txt from data\installs
3. Delete xedilco.pkg from data\packages
4. Delete xedilco folder.

But after doing that, GSB won’t even start. The splash screen comes up but the main menu never appears on top of it, and hitting any key or clicking anywhere causes an immediate CTD.

So, what’s up? I restored all the Xedilco stuff and the game at least launches again, but still the ship editor won’t work from the main menu.

Anyy ideas? Thanks in advance.


#2

Is this after you have unlocked them from the Fleet HQ - Ships Hulls Tab ?

One possibily (of several) is that there is a hull that is not linked to a race file. One way to check this is you could play as each race and try and design a ship. If it crashes at any point then turn that mod off (rename the install\ModName.txt to .off) and try to see if the game crashes.

That is rather strange that after uninstalling the mod, GSB fails to work. It might pay to look at the debug.txt file.


#3

^^’
To uninstall Xedilco, you must remove the GGormaul and Pavise Bomb from the “sampleship” folder in the main data folder.

I don’t know why, by there is some sort of curse on my Mod -.-

!!!
The error message display (when it display) behind the game, must do an ALT+TAB.

(Note to myself, add a readme ^^’ )


#4

Thanks for the help, guys. Following your advice, I have manage to eliminate Unity as a suspect. It seems to work just fine in all respects. I’m sure Darkstar076 is quite relieved :).

Now, as to the other problems:

Classic Dreadnoughts
There is no trace of these in the game at all. Neither they nor their unique modules appear in Fleet HQ, whether locked or unlocked. They are not in the ship designer, and there are no battles involving them (if there’s supposed to be any–I don’t know).

I installed the Classic Dreadnoughts by unzipping the archive into C:\Program Files (x86)\Steam\Steamapps\common\Gratuitous Space Battles. That was a guess because again, I couldn’t find a README for them, but that’s what all the other mods wanted. Is this the correct place for them?

Now that I’ve successfully uninstalled Xedilco (see below), my Fleet HQ store has the normal stuff from the base game and official DLC, plus the Unity stuff. On the theory that the Unity stuff might have overwritten the Dreadnought stuff, I uninstalled and reinstalled Dreadnoughts on top of Unity. This had no effect. Unity is still there just fine and there are still no Dreadnoughts.

Xedilco
Just to make sure, I have Xedilco v1.4. Is that the latest?

Xedilco definitely caused the problem with using the ship designer from the main menu. Following Darkstar076’s advice, I went to the battles section, selected each race in turn, and then tried to use the ship designer from the deployment screen. This worked perfectly for everybody except Xedilco, where the effects were the same as if I accessed the ship designer from the main menu. That is, the designer would come up showing some random existing design and hitting the CHANGE button immediately crashed the game. I ran the game in a window to look for error messages but there were none, just an instant “GSB has stopped working, Close Program” box.

I was able to uninstall Xedilco by deleting the following things:
File: \data\installs\xedilco.txt
File: \data\packages\xedilco.pkg
File: \data\sampleships\pavise bomb.txt
File: \data\sampleships\xed ggoremaul.txt
Folder: \GSB\xedilco

Once I did this, GSB resumed normal operation, in that I could then use the ship designer from the main menu. However, I can’t use Xedilco, which is a bummer.

BTW, there’s 1 more file to add to the list above if you want to do a total uninstall of Xedilco, although leaving it there seems to cause no problem. This file is:

GSB\data\sounds\music\Comand_&_Conquer_Red_Alert_March_to_the_Apocalypse_OC_ReMix.MP3

I found out about this file when I tried to re-install Xedilco just in case I’d screwed that up the 1st time, and got a message about overwriting the above music file. I’ve decided to leave this file because it’s a good piece of music :).

Anyway, the bottom line is that there’s something wrong with Xedilco that appears to be ship-related, but I can’t tell what it is because I get no error messages when it crashes the game.

Thanks again for the help.


#5

Many mods (including Classic Dreadnoughts) require you to add an install file (usually it’s in a folder named data), and then add the mod folder to the main GSB folder.

If something isn’t running properly in GSB (crashing, not loading, etc), go to the “My Games” folder (should be under “My Documents”) and run the errors.txt file in its GSB folder. Any errors which occur should be displayed in this file, which should help you fix them.


#6

Thanks for the help.

Please explain this in more detail. I’ve got no idea what you’re talking about here ;).

Ah, thanks. Now I’ve found the problem with Xedilco:

14/10/2012 - 3::50 - Ship Hull not found ->Xedilco Large Station:…\src\SIM_ShipHull.cpp 503
14/10/2012 - 3::53 - Ship Hull not found ->Xedilco Large Station:…\src\SIM_ShipHull.cpp 503
14/10/2012 - 4::1 - Ship Hull not found ->Xedilco Large Station:…\src\SIM_ShipHull.cpp 503
14/10/2012 - 4::2 - Ship Hull not found ->Xedilco Large Station:…\src\SIM_ShipHull.cpp 503


#7

Well there’s your problem

look when your modding a game you gonna need some smarts, you can’t just rely on a readme

also you may consider looking in the folders, because classic dreadnought does have a readme

 [Classic Dreadnoughts v1.00.zip\Classic Dreadnoughts v1.00\Classic DNs\]

and as for basic instillation, which is almost the same for EVERY mod:
you simply place the folder of the mod into it and that should add the stuff right
as for mod like Classic Dreadnoughts its affiliated with the data folder and you juts have to drop the data folders from

[Classic Dreadnoughts v1.00.zip\Classic Dreadnoughts v1.00\Classic DNs\] and [Classic Dreadnoughts v1.00.zip\Classic Dreadnoughts v1.00\] and just drop the data folders onto it it will ask if you want to merge and you say yes make sure there are no files put in that use window’s blank page icon

also Archduke after reading the readme, i think it’s a tiny bit vague
also i noticed that the windows version has a lot of unrecognizable files you may want to clean that up


#8

That error come from when you didn’t unistall all the Xedilco files (The sampleship hull to be precise)

If you clear the log and relaunch the game with xedilco active, if the hull design crash come again (and if it’s the same that the one I got) the log will not be filled with text -.-

Xedilco 1.4 is the latest

EDIT: Try to suppress “Xed Destructor” (not “Xed zz Destructor”)
EDIT2: Test that one plz: mediafire.com/?swpcs20mlcfo1l8
I got a similar problem with Zombie mod, when I unistall it, all when to normal -.-


#9

Well, thanks to your info, I was able to figure it out.

I’m totally unfamiliar with modding GSB so I naturally have no clue what files need to go where. When the readme says “just unzip into the main GSB folder”, that’s what I do. It worked for Unity so I expect it to work for everything :).

Anyway, with your help, I now have Classic Dreadnoughts working. Thanks muchos.


#10

Well, that’s exactly what happened. I reduced the error.txt file to a blank page, re-installed Xedilco v1.4, got the crash on the ship designer CHANGE button when accessed from the main menu, and there was nothing at all to show for it in the error.txt file. Still all blank there.

I have no idea what this means. Sorry for being such an ignorant noob.

Well, I tried v1.41 from the link above. It made no difference. Same crash when hitting the CHANGE button, nothing showing in the error log.

Thanks for trying.


#11

OK, what exactly are:
1)The list of mod installed.
2)The list of DLC you own. (THE GREAT QUESTION: do you own Parasite?)


#12

I have the following mods installed:

Classic Dreadnoughts
Unity

I own all official DLC including Parasites.


#13

T.T

OK, who have throw a curse on my mod? WHO?!

It’s working perfectly fine on my PC, and to test it, I have install the .rar I have release and deactivate all other mod!
I have Unity too on my computer and their is no problem!

WTFake!


#14

While i have no doubt you gentlemen will be able to sort out the problem in short order.
If you can provide me a link to v1.4 - I can have a look and remove any curses if you wish
I stepped back earlier on - since had an earlier version and could not find the link to 1.4
also everyone was ninja’ing what i was about to post :stuck_out_tongue:


#15

Here is the 1.41
mediafire.com/?swpcs20mlcfo1l8


#16

I’m pleased that my Classic Dreadnoughts is now correctly installed and fully functional for you. I do regret the spot of trouble you found yourself in [-embarrassed blush-]! When time permits, I intend to revisit my readme.txt therein. Despite being downloaded by well over one thousand GSB players as of January of this year, I have received only a scant handful of reports from folks across the prior year-plus who had any trouble installing it. I will re-examine things to see if I can simplify them further.

Telling me exactly where you feel that it’s vague - and why - would be a lot more more helpful than the above comment, which is very much like saying “I see something that I personally dislike or disagree with, but I’m not going to tell you what it is or why I feel it’s objectionable.” :stuck_out_tongue:

Thanks for jogging my memory about that. Here’s what causes it:

The mod was created on a Mac, even though Windows-using players make up the majority of its audience. The files you refer to are hidden Apple OS X files for maintaining the standard Mac Finder desktop database and are therefore unavoidable when copying the mod into a Windows computing environment. I don’t own a PC any newer than a uselessly underpowered 10-year-old hunk of garbage, so mod development on that machine is not happening. While I freely agree that those files are a small annoyance, they are also harmless and in no way impair the functionality of the Classic Dreadnoughts content.


#17

mainly the instillation, cause you don’t juts unzip the folder into the ‘place where you installed GSB’ that’s vague and missleading

so if those go into gsb they wont screw anything up for me then?


#18

It could be that most folks are familiar with GSB mods so know where the various files are supposed to go, put them there manually, and go on without feeling the need to comment on it. I am only beginning to get a handle on this, however.

However, this doesn’t work (at least not on a PC), because the archive actually unzips with the structure shown in the attached pic.

So, the real installation process (at least on the PC) is as follows:

  1. Unzip the “Classic Dreadnoughts v1.00” download into a temporary location somewhere. Because of the included text files, I do this as shown in the pic to a place I call “GSB Stuff”, so I can read it later.

  2. Move the \Classic Dreadnoughts v1.00\Classic DNs folder and all its contents to your main \GSB folder. Delete the redundant zipped \modules folder if desired but it does no harm to leave it.

  3. Move the contents of \Classic Dreadnoughts v1.00\data\installs to GSB\data\installs.



#19

Well, I’m sure you wouldn’t have released it if it didn’t work on your end. So I’m not blaming you and I’m sure it’s something unique to my system.

Here are some more observations from trying v1.41.

I’m pretty sure the problem comes from a hull or module, or maybe some of each as I see there are quite a few of both in the mod. In situations where the game has no need to look at Xedilco hulls and modules, there’s no problem. Thus, I can play all other races in battles and challenges, because when you access the ship designer from the deploymnet screen, you only get that race’s stuff, not the full selection. However, if I’ve selected Xedilco as my race, the game crashes in the ship designer. When the game crashes in the ship designer when accessed from the main menu instead of the deployment screen, I figure it’s because then the ship designer has access to everybody’s stuff, including whatever Xedilco pieces are causing the problem.

Interestingly, I can fight the 1st Xedilco battle without crashing the game. So, if there’s a problem with some specific Xedilco part, either it’s not included in this introductory battle, OR the problem it has doesn’t affect the game when the AI has it but not the playr. I hope it’s the former because that would help you narrow down the list of suspects. I have not won this battle yet, so haven’t unlocked any more battles, so can’t tell you where the problem part comes in, or even if it ever does.

I also noticed some interesting things in the Fleet HQ. This initially opens showing the Modules tab and there are zero Xedilco modules there. But if I go from the Modules to the Hulls tab, the game immediately crashes. OTOH, if I go from Modules to Races, the game keeps running, although Xecilco doesn’t appear, just the races I already have. AND, I can go from Races to Hulls and the game keeps running, although there are no Xedilco hulls shown. Hulls to Modules, game still running but still no Xedilco modules. But from Modules back to Hulls still causes a crash.

It occurred to me that perhaps you didn’t include all the hulls and/or modules in the archive. You don’t notice a problem because the “missing piece” is already on your machine because you created it, but I never had it, not even from an earlier version of the mod, so it’s killing me. So, here’s a list of the Xedilco hulls and modules that come in 1.41:

Hulls: Total of 18
Xed Battlebarge
Xed Battlecruiser
Xed Destroyer
Xed Dreadnought
Xed Fastfrigate
Xed Heavy corvette
Xed Platforme <----- Is the final “e” supposed to be there?
Xed Supercorvette
Xed Supportcruiser
Xed y Tac Cruiser
Xed y Tac Fighter
Xed y Tac Frigate
Xed yz Small Station
Xed z Large Station
Xed z Medium Station
Xed zz Destructor

Modules: Total 51
xed_battery
xed_bomblaser
xed_cr_bucklercore
xed_cr_exoskeleton
xed_cr_guardianshieldv1
xed_cr_guardianshieldv2
xed_cr_guardianshieldv3
xed_cr_guardianshieldv4
xed_cr_lasergat
xed_cr_lasergatrf
xed_cr_subspace
xed_cr_subspaceC
xed_cr_subspaceP
xed_cr_subspacestorm
xed_cr_subspaceT
xed_ecm_shield
xed_fi_wave
xed_fig_cr_shield
xed_fighter_engine IV <— no underscore between “engine” and “IV” if that makes a difference
xed_fr_exoskeleton
xed_fr_guardianshieldv1
xed_fr_subspace
xed_fr_subspaceC
xed_fr_subspaceP
xed_fr_subspaceT
xed_goreistm
xed_gormaulrep
xed_hypercrew
xed_hyperengine
xed_hyperpowergenerator
xed_hypershield_fastrecharge
xed_istm
xed_micro_repair
xed_minimissile
xed_plasmashotgun
xed_plasmashotgunrf
xed_shadowartillery
xed_shadowcannon
xed_shadowcannonl
xed_shadowcannonrf
xed_shadowhunter
xed_shadowhunterrf
xed_shadowreaper
xed_shadowreaperrf
xed_stationelite
xed_storm
xed_stormcm_shock
xed_stormrep
xed_submine
xed_wakarmrep

Hope this helps.


#20

French deformation ^^’

I think (and don’t know why and if it’s really that) it’s coming from the “y” / “yz” / “z” and “zz” in the name of the last hull files.
Try to remove this letters on the files names. (I got the hull crash again, and it disappeared when I remove the letters -.-)

I don’t think so, but I correct it anyway