Right side graphics streaked


#1

Couldn’t find any other reports of this bug on the board.

I’m getting horizontal streaks on the right quarter of my screen in every battle. For the entire length of the battle. See attached screenshot.

Using the latest NVidia drivers. Windowed mode didn’t make a difference. Zipped DxDiag.txt attached. Version 1.02 runs fine otherwise. No crashes or other obvious problems.
DxDiag.zip (4.78 KB)



#2

You’re problem is related to you kickass monitor. The game doesn’t support 25601600 resolutions. (yet). If you set your resolution to 19201200 or so the streaking will stop.

I remeber a twitter message from Cliffski regarding this issue.

"So it seems some peoples monitors are wider than 2048 res. Holy crap. Should ahve seen that one coming really…
5:14 AM Aug 31st from Twadget "

I would love to see support for 2560*1600 resolutions in the future.


#3

I do have it too sometimes (though its a few pixels wide only) and my resolution is 1280x1024.


#4

Odd, then the problem is bigger than expected. I’m still fairly certain the OP’s problem is related to the size of his monitor. His screenshot is 25601600 which is the native res of 30" monitors.
I have exactly the same problem when I put my monitor on 2560
1600 and it’s consistent.

Are you running 1280*1024 is the native resolution of your monitor?


#5

Yes it is the native resolution. The glitch appears constantly if I turn on camera motion blur. If it is tuned off everything is ok.


#6

If you have motion blur on then you do get a small bar of streak on the right when the screen shakes from explosions. I was staring at that when running in 1024x768 windowed mode this lunchtime and I couldn’t figure out if it was a deliberate part of the motion blur & shaking effects or not.

I guess with the super huge resolution all of the unexpected screen estate gets turned into the streaky bar.


#7

Going back to my original bug.

Turning off Gratuitous Shaders in the Video Options solves the streaking problem at 2560 x 1600.

As Zarkov suggested, running at 1920 x 1200 with Gratuitous Shaders turned on also has no streaking.

See the pretty screenshot 2560 x 1600. :slight_smile: