weird Mac recent update problems help


#1

This is a help thread for people who will get the same problem:
Problem:I opened up GSB, the window popped up saying that a new version was available. I clicked download. It finished and said that it was successful. But now when I try to open it up it says: “Fatal Error: Operation EnsureDirectoryExists failed.” I have- or, more properly, had, version 1.50. I am assuming it was updating to the version 1.55 I have been reading about here (and I found it was after I got it to work).
Fix: I right clicked on Gratuitous Space Battles and selected “Show Package contents”. Then I took everything out of Contents/Resources/data/installs, and moved the GratuitousSpaceBattles folder out of the Users/Your name/Library/Preferences folder. I opened up the game. It worked, but the campaign background was gone (I had taken away what told it where to look). I moved everything back and now it works fine.

And I end with a question: Does Version 1.55 for mac come with the ship hull editor? its not in options…


#2

I had the same thing happen this morning. What fixed it for me was to click the game in the steam library, select Properties, go to the local files tab and click the button marked: “Verify integrity of game cache…” It found 16 suspect files and replaced them. So far the game is working fine…


#3

I didn’t have a problem immediately after updating to Mac v1.55.1, but upon running a challenge and trying to retaliate, it crashes. Or it least it has done so twice so far. . .

RC


#4

actually I did try to retaliate a challenge after I ‘fixed’ it, I guess there are still issues like this, and it crashed. Didn’t send the message or challenge. I didn’t catch it at the time because it was my first attempt at retaliating, Im a noob XD, I thought it was just a one time thing or weird computer-specific bug.


#5

1.55.1 had a crash bug in it, which we quickly corrected with 1.55.2. That’s the version everyone should be using now. If you have any trouble upgrading, just let us know. (For Mac App Store purchasers, sorry, the update is still awaiting Apple’s approval).


#6

I currently have 155.2 (MAC) and am having the update issues. There is apparently a new version but it never installs? I also have the issue where the game crashes every time I issue a challenge. As an aside, should there be a an official thread post about MAC related issues? -Thanks, Hugo


#7

Same problem here.


#8

Any help?


#9

What does one need to do to get support form this company? Emails? -No response… I need a support on how to get a hold of support… What’s the deal?


#10

Sorry, out of town briefly. Responding to your email now …