1.18 Save Files -> 1.18a Save Files


#1

– November 26 '06: Patch 1.19 solves this issue –

I had a feeling something in the format would change between the two patches, and I was right! :smiley:

I try loading my old 1.18 savegame into 1.18a and get the following error:

Interest type not found:.\SIM_Interest.cpp

After digging around a new 1.18a save file I found that the interest cardgames has changed to card games, so I go back and update all instances. Still won’t load, get the same message. Deleted all blocks that look like this:

gambling card games Card games # gambling Gambling

The old save game loads fine after that. I triple checked my changes against the new format… did I still miss something?

[EDIT]
Notes for the curious:
By deleting those blocks, any friends that used to play poker will no longer have the Poker interest.


#2

This is true, it had to be done for tedious reasons concerning international translations…


#3

Thanks! got an xml editor from tucows and deleted your string and it worked. Just sorry I deleted all the non working games … oh well.

Thanks!


#4

The next patch will fix it up proper. See below. :slight_smile:

Referenced from the ‘Known Bugs…’ thread found here.


#5

cliffski,

Is there a possibility this thread could be removed? It started as a simple question and suddenly turned into a hotfix that never should have been. I’d feel terrible if somebody unwittingly mangled a save they had worked very hard on by using this information.

Thanks in advance.


#6

ahhh. I think its quite helpful actually. It should be moot by tommorow when I finish the patch. Once i know its not an issue, Ill delete it.
Cheers


#7

Really? Well in that case never mind. :blush: