Could someone uploadme patch 1.55


#1

since Cliffsky seems to busy to help me with this:

Could someone upload me 1.55 patch please :slight_smile:


#2

Iā€™m not too busy. Just redownload the installer, they are automatically updated to be the latest version.


#3

i assume the original GSB installer or the Gaalactic Conquest installer ???
If it is Galactic conquest i must ask you send me the link again to my email, please.


#4

Done, cheers


#5

Thank you very much everything looks fine now :slight_smile:
Cheers