Crash when autoupdating


#1

My game just crashed when i was trying to autoupdate and get the Veterans Benefits policy.

The txt files were downloaded normally, but just after starting to download the icons_veteransbenefit.dds the game crashed to desktop displaying a message box :

IERROR: Failed writing local web copy

I have version 1.06 (but it is heavily modded , if it may have something to do with the problem).


#2

eeek. You might have been clicking it just as I updated it. Can you try just ditching the whole Democracy2 folder in MyDocuments (or renaming it). And then trying again. Hopefully it was just a glitch.


#3

I deleted the democracy2 folder in My Documents,re-entered the game code in the online window , then clicked the update button , but the error happens the same, nothing has changed.


#4

I’ve tried various things here to reproduce this but cannot. Does it re-download all the other files ok?
Is there a MyDocuments/democracy2/mods/data/bitmaps folder?


#5

Yes! That`s what it was, there was no bitmaps folder in MyDocuments/democracy2. Now when i created it the update works fine. Thanks for the help and sorry for the trouble.


#6

I’ve just tried to update mine and get the same problem. I’ve fixed it in the way you suggested above, but presumably there should already have been such a folder/it should have been created by the autoupdater without the need for me to create one?


#7

Aha. Grrr. Its my stupid fault. the bitmaps folder is being created correctly in the (upcoming) 1.07, but it wasn’t showing up in 1.06.
Damn. I’ll remove the policy until its released.


#8

Hi! I has the same problame. I created the bitmaps folder, the update was continued, but it failed at an other file. What folders needs to be in data? I have mission and simulation and bitmaps only. THANKS


#9

what version are you running? if its an old version I strongly recommend just re-downloading the whole game from the original download link in your order email.


#10

I’ve got 1.6 (or 1.06?).


#11

in that case redownload the game using your purchase email, then it will be updated.