Crash without error with modded ships


#1

I made a new race and a cruiser hull (with .dds images) to go with it, and I designed a ship with my new hull, but whenever I try to play a scenario with only that hull, the game crashes without giving me any sort of error message. If I play using a vanilla hull and my modded one, everything works fine. Sometimes it crashes while it’s loading, while other times it crashes when the modded ship dies.
I have made a few other modded ships that never had this sort of crash and used those files as reference, but while those work, my new one doesn’t. I’ve double checked all my new files for spelling errors and I know it’s not the race file that’s messed up.
Has anybody else ever encountered something like this? If so, how did you fix it?


#2

it could be because of the width of the ship. For some, the width cannot go above 270 while for others it can go all the way up to 300. This does not apply for height.


#3

Changing the width and height from 350 to 270 fixed it, but I have another ship with a width of 290 that still works. And that still doesn’t explain why it worked when I used it with a vanilla ship.