D3DE Engine Error

First try at running Democracy. No luck. I get the above error message.

I am running on an Acer 8920 Laptop under Vista.

i have core 2 Duo processor T9300, with 4Gb RAM
My vidio is NVIDIA GeForce 9500M

I reckon the hardware is plenty ( It will run Oblivion !!!)

Any ideas please???


1 Like

HELP !!!

Still waiting a reply


Does anyone read this forum???

Does anyone from Positech answer queries???

Still waiting on a reply !!!

Which version of Vista?

Is there any other text in your error message?

I’m running Vista Home Premium with Service Pack 1.

Just the above error quoted, plus:- Please check publishers website tech support Details:

Hence my using the tech help forum on the Positech website

Cheers & thanks


Hi, what’s the screen resolution of the laptop? I bet the screen height is fixed and too low to support the game.

Screen reolution is 1400 x 1050. 32 bit colour.


It sounds like the game cant switch the screen to its default resolution. does the error happen immediately? If you open up the file inside democracy\data called ‘config.muf’ and change the line that says IsWindowed=0 to Iswindowed=1 (you can open it in notepad) it should run ok.

Hi again.

The initial Democracy screen comes up. I move the cursor to PLAY and the error screen comes up almost immediately.

Tried the fix in config.muf. no go.

I changed the IsWindowed line to =1. Checked that the change had happened - It had.
Still the same error screen. I rechecked in config.muf and the IsWidowed line had reverted back to =0 !!!



I’m getting the same error, and this is what my ‘config.muf’ file reads:



I’m running Windows XP with a GeForce 7950 GT video card. Any help would be greatly appreciated!

I would recommend trying screen height as 768, screen res at 1024 and windowed as 1, with colordepth at either 16 or 32. One of those combinations should work on your video card, unless you are using a laptop with a screen height below 768.


Screen height is set to 768 and width to 1024. 16 bit or 32 bit colour makes no difference.
What is puzzling is that I set IsWindowed =1 ( confirm the setting before running Democracy), but it still fails and Democracy itself has changed the line to IsWindowed=0



Couldn’t agree more. I’ve not had problems with Democracy but I’ve had them with several others games. Now problems now that I installed W7 instead, I might add! Screw Vista! hope you got your errors sorted out, Ken!

So I checked the “force resolution” option on arkaos and exited out of the preferences menu.
A message pops up stating
“The engine failed to start, please check the display preferences”
I attached a screen shot.

I thought it might be the display prefs on my operating system, but after trying all of the options and still getting the same message, I dont know what else to do. I am also running the new beta version of grandvj and with that version the same message arrives.

Arkaos will not let me access the pref menu so that I can uncheck this force resolution option

I tried uninstalling the two versions of the program and reinstalled, but the same problem is plaguing me.

Any help is much appreciated

1 Like