Democracy 3 on Linux with weird graphic glitches


#1

Hello!
I’ve installed Democracy 3 via Steam on linux and I’m seeing some strange graphic glitches.
My configuration is:
Arch Linux with KDE 4.14.1, Nvidia Drivers 343.22-2. GeForce GT 560M. Any other info that is relevant just let me know.

The problem can be seen on this video: dropbox.com/s/gj8hf80tmt5k2 … 7.mp4?dl=0

I can’t seem to take a screenshot of the problem, in the screenshot it seems alright.

Any tips on how to workaround the issue?
Best,


#2

I had the exact same issue with Ubuntu.

Verify that the OpenGL renderer is actually using your NVidia card (in my case, it was using the integrated Intel card) … and also the nouveau drivers instead of the NVidia drivers.

Check this post: ubuntuforums.org/showthread.php?t=856313

Basically, run glxinfo | more and look for the OpenGL renderer string.


#3

Hi, ProfM!

My renderer is using the NVidia Card:

$ glxinfo | grep -i render direct rendering: Yes OpenGL renderer string: GeForce GTX 560M/PCIe/SSE2

I didn’t want to change to nouveau unless I had no other option. I played some games in this setup and didn’t have any problems regarding flickering or other stuff like this. Is there any configuration I can do in democracy client?

Best,


#4

Hate to say, but this change from my Internal card driver to the NVidia card driver fixed my issue.

However, I do know that, in fixing my issue, I had to remove the driver for the internal video card. The “open” nouveau drivers don’t have to be removed (according to some other forums I’ve read), I did end up removing them.

Since I’ve fixed the flickering issue, it created a new issue that doesn’t allow it to be windowed for some reason. Anyway, I would pursue the driver issue a bit further.


#5

Well, unfortunately, this is where our two system diverge. My issue was that Ubuntu was using the built-in Intel graphics and not my NVidia card. Once I got that resolved, all of the flickering issues went away.

In my process, I did delete the nouveau drivers, and used the binary drivers from NVidia, instead of the older packaged drivers from the Ubuntu repository.

As far as any settings in the client goes, I haven’t been able to find any.