Hang on launch with non-default user folder location


#1

I’m running XP x64, and the path to my user folder is D:[username] instead of C:\Documents and Settings[username].

When I launch GSB, nothing happens except that a process appears in task manager fully-utilizing one CPU core. This is different than the other failures on launch I see on the forums, where error messages, audio, or a title screen are involved. Absolutely nothing happens onscreen.

No debug data or ini files are getting written anywhere, which is why I think there’s a problem with a hardcoded path or drive letter not liking my nonstandard user folder location. When I posted this issue on the Steam forums another user said they had the same problem, but it’s dead over there and nobody had any useful feedback.

  • Yes, I’ve uninstalled and reinstalled from Steam. Several times.
  • No, I’m not running AV at all; don’t need to disable it.
  • Yes, I’ve tried running the .EXE from Windows Explorer instead of launching through the Steam interface.
  • Yes, I’ve tried running \directx\DXSETUP.EXE.
  • Yes, I’ve tried creating the folders GSB is expecting to find in the places it’s expecting to find them.

#2

G’Day jackbird and welcome to the forums.
Looking at your comments, I don’t think its the path.

For example:
At home I have 3 GSB icons and they point to 3 separate locations

  • E:\games\Original Gratuitous Space Battles\
  • E:\games\Modded Gratuitous Space Battles\
  • E:\games\Testzone Gratuitous Space Battles\

Question:

  • Do you have a firewall in place and does GSB have permission to use the internet ?

#3

The game definitely has no hardcoding of locations, it just asks windows for your MyDocuments location and goes from there. It might be video/soundcard or firewall related.


#4

My system config is fairly vanilla:

Core2Quad 6600
nVidia 6800GT driving 2 monitors (have tried launching with 1 monitor disabled)
nVidia driver version 306.23
WinXP x64 SP 3
realtek HD audio on motherboard (driver version 5.10.0.5559)

no software firewall
no antivirus
no unusual hardware other than a wacom tablet and WIBU authorization dongle

thoughts?


#5

heh - I wish i had your “fairly vanilla” setup.
(everything looks standard, except i have never come across WinXP 64bit installation before)

My thoughts at the moment are along the lines of:
“I wonder if WinXP 64 bit is not handling the game as it should.”
(Again: my knowledge of winXP 64 bit is non existent, so take the following suggestions with a grain of salt)

At this point in time my only suggestions are:

  • does WinXP x64 have an 32 bit compatibility option for the short-cut to the exe ?

  • if you have access to another computer to test the game ? (by that i mean, to place your version on a USB stick and try another system - ie win 7 or XP professional.)


#6

XP automatically use a 32 bit compatibility if the programme is 32b.

I don’t have any problem with my Win7 64bit

Did you have any modded contents?


#7

Just making sure, so the My Games folder doesn’t have the debug or anything? Debug is in there, not the GSB folder so I just want to check.


#8

I hand-created the following folders, but none ever had anything written to them:

C:\Documents and Settings[user]\My Documents\My Games\GratuitousSpaceBattles
C:\Documents and Settings[user]\My Documents\My Games\Gratuitous Space Battles
E:[user]\My Games\GratuitousSpaceBattles
E:[user]\My Games\Gratuitous Space Battles

I’ve tried installing the game both in:

C:\Program Files (x86)\Steam\steamapps\common\Gratuitous Space Battles (default Steam library)
and
D:\games\SteamLibrary\SteamApps\common\Gratuitous Space Battles

no mods; I haven’t ever been able to so much as see the title screen.

I assume if I logged into Steam from another machine, downloaded GSB, and ran it it would likely work fine, as the game generally works for most users. As far as my particular download being corrupt, I’ve re-downloaded and reinstalled from Steam 4 times.

UPDATE: Have now tried making a shortcut and running as Administrator (although my regular user account has admin), as well as in XP and Win2k compatibility modes. No luck.


#9

One other odd thing; it seems like it hangs with very little loaded into memory; task manager shows a 9,608K footprint with a VM size of 7,620K.


#10

Have you tried installing and running the ‘non-steam’ demo?


#11

Just installed the demo and it works fine. This did not, however, knock something loose from the Steam version; it’s still defunct.


#12

Is there a way to use my Steam key to validate the demo?