Humble Bundle Steam version won't launch at all


#1

I installed GSB using the Humble Bundle 6 Steam key, and when I go to launch the game, I get a wait cursor for five seconds and then nothing - No game screen, no error messages. A GSB process appears in Task Manager and sits at 100% utilization of one of my cores which must be killed manually. This appears similar to problems some other people have mentioned, but the solutions they’ve tried don’t work for me. I’ve tried:
Updating my video drivers (Latest nVidia WHQL)
Launching the game directly from the .exe in the install folder
Launching with Run As… Local Administrator
Disabling my 2nd monitor in Display Properties
editing prefs.ini, except it’s nowhere to be found
Manually creating c:\Documents and Settings[username]\My Documents\My Games\GratuitousSpaceBattles and [odd actual My Documents subtree location]\My Games\GratuitousSpaceBattles (with and without spaces in the GSB name) in the hope that the game creates a prefs.ini when attempting to launch.

There are a couple of odd things about my configuration that may or may not be relevant:
Win XP x64 with 8GB memory
Dual Monitors (on a single nVidia 8600GT)
The My Documents folder for my user account is not on C:, but the overall Documents and settings folder is. This has badly confused a couple of applications in the past, and I was totally unable to find a prefs.ini file in either of the locations it’s reputed to reside.

What should I try next?


#2

Same issue here!
I tried to launch it with the GSB.exe file located in the SteamApps folders but it says the d3dx9_41.dll file is missing.

I run a PC with Win7 and 4 GB memory.

Thanks in advance for your help!


#3

The only thing i can think of is to get steam to reverify the install and make sure all the files are there.


#4

You’re right, it may come from Steam. I will try to install the game directly with the installer file and see if it works.
I will keep you up to date.

Edit: the game starts fine when I install it outside of Steam. Besides, it runs fine on Steam on my other PC (Win7, 4 GB). I don’t know what to think…

Edit 2 : OK, I got it! Actually DirectX wasn’t up to date. When I installed GSB with the .exe file, it automatically updated DirectX with the needed .dll files. Now it works fine on Steam!