Hidden Windows XP window's hidden bar


#1

It seems that when I run the game in fullscreen mode (under windowd xp + steam), the usual window bar with the minimize, maximize and close buttons is just kindof hidden by the game display, but still active and responsive. I still can accidentally click on those 3 buttons and minimize or even close the game. When in all case it either shuts down the game (obviously) or when minimized or maximized, the game rendering seems to stop somehow and doesn’t come back. I need to kill the game and restart it to be able to play.

Am I the only one who noticed this? (its kindof annoying, but its not so bad either once you know about it).

It also disables me to place ships on the topmost grid positions, or hinders the process of doing it.

BTW, thank you for this great game ^_^Y

Edit: Uhmm, sorry for the extra ‘hidden’ in the title of this post x_x…


#2

This is a known problem that is hard to replicate and comes and goes. It’s something that will be fixed the minute the true cause of it is known. It doesn’t seem to affect everybody, somehow :frowning:


#3

I have the exact same problem, also xp and steam, the start bar sometimes flashes up and is clickable too but the top bar is de most anoyig, partially going over the save deployment screen


#4

i tried the game on several XP systems (6 or 7,dunno) and never came across the problem… used original nonsteam version of the game each time tho
virtually every single one of the compys had different hardware config and/or different version of windows XP (in each case fully updated)

if its a steam-specific problem im gonna laugh so hard :slight_smile:

edit: the computers had Intel GMA chipsets and Nvidia cards, you should post your system config guys else were never gonna figure it out
i bet its caused by graphics drivers, unless its really steam doing it


#5

I just tried the steam version on my machine and its not doing it in that either. I have seen it before though, so it must be some specific set of events :frowning:


#6

Also intel and nvidea here, il see if I can upgrade the drivers.


#7

i meant Intel Graphic Media Accelerator,the integrated graphics card,some of them actually had nvidia graphics cards
not really sure what kind of MB/CPU they had but atleast 3 of them had intel processors, if that info counts for anything…


#8

Something like this happens on my version of GSB (straight from positech) but only in one specific circumstance. I play the game full screened - and if something causes it to minimize and goes to the windows (W7) main screen. Then if I click on GSB the top edge becomes unclickable and the bottom edges refer to the task bar (though the task bar items are invisible).

Usually it is when I quit soldier front, and start GSB - the soldier front end pops up about a minute later.

So for me it is an easy workaround - I quit soldier front and get a coffee, then close/minimize the front end then play GSB - and all is normal.

I have a laptop with an Intel graphics driver that is updated.

Berny


#9

yeah thats a “microsoft being gay” issue tho… quite common really…
i have XP and it happens to me too,thats why i tend to switch whatever can generate a popup into a mode that forbids it or just turn it off while playing…
especially annoying with MSN popping up…


#10

I’m having a very similar problem.

During Deployment, in regards to registering a mouse click (or getting the context mouse pointer- the hand thing), I have to be on the bottom few pixels of the Save Deployment, Mission or Supplies button. The odd thing is that the hover highlight and tooltips work correctly, i.e. the button highlights properly when the regular mouse pointer is over it- it’s just that the zone for the mouse click or getting the hand pointer is off. Initially I could not even click on the mission and supplies buttons during deployment, but then I went into the display settings for vista and turned the DPI scaling that I had for the fonts off (reset it to stock) and then I was able to get the behavior stated above.

I bought the game through impulse, though I’m not launching it through impulse.

I do not have this issue in windowed mode, though I hate playing in windowed mode.

I think this is directly related to the issue that the above posters are having. If I click and drag on the aforementioned buttons while they have focus (are highlighted) but don’t have the hand mouse pointer I can drag the window around.

I’m running the following:

EVGA 790i mobo
EVGA NVIDIA GTX280
Winows Vista 64
Samsung 42" through HDMI (using the card supplied DVI to HDMI adapter)- 1920x1080 (I have the same problem though on a LG 19" through DVI)

I thought it might be related to the fact that I normally auto hide the task bar, but I’ve disabled that rebooted and retried- no dice.

This problem does not come and go for me, it is always present. I’ve attatched the debug files.

Let me know if I can try anything else. I’ve tried a lot of different things over the past couple of hours- it didn’t bother me initially but now I’m on a mission with a supply limit, so I’m obsessing on getting this resolved. As I said before I really hate playing in windowed mode.
debug.zip (2.35 KB)


#11

I’ll be honest, I have no idea why this is happening in your case. I’ve managed to ensure it never happens on my machine with version 1.45 (which you have) but I totally accept it must be happening for some people with specific driver/O/S/video card combos.
I have a horrible feeling this is video card driver related, and not something I can fix :frowning:


#12

Cliff: I believe it may bay dual or more core computers. Set affinity to one processor. Works for my problems!

EDIT: Happened to me before I used steam for it. (Demo)


#13

I don’t believe it is a problem related to the number of cores, since my computer is a older single core AMD processor. I also have an Nvidia video card (GeForce 9600) though, so it might be related to thoses drivers?


#14

Yeah, I just ran it with affinity to each core individually and it made no difference. I haven’t tried to go retro on my NVIDIA drivers yet though, it’s a pain and I haven’t done it yet with the PhysX couped with them, unsure if I’ll have to go retro with those too. Maybe I’ll give that a shot this weekend when I have more time to spare.