Monitor Resolution Change Crash


#1

I normally play the game on an external monitor. It works fine, but when I travel I can’t take my monitor with me. Instead I have to play it on my laptop monitor, at which point the game crashes on startup.

My laptop monitor’s resolution is 1366 x 768. Looking through the debug info, it appears that the game is attempting create a 1280 x 1024 window and failing (since my monitor only supports heights up to 768). I suspect I can semi-fix the problem by changing my resolution when I get home to never exceed the size of my smaller monitor, but that sort of defeats the purpose of having my large external monitor in the first place. It would be nice if the game checked for available smaller resolutions when opening if the initial attempt failed.

I’ve attached the debug info below. All told, it’s been a great game and this bug isn’t going to stop me from picking up the expansion packs, it’s just annoying and could be a turn-off to somebody else interested in the game.

Initialising 3D Engine
Driver : nvd3dum.dll
Description : NVIDIA GeForce GTX 260M
DeviceName : \.\DISPLAY1
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
About to Create 3D Device with width: 1280 and height : 1024
Attempting hardware Vertex Processing


#2

This might fix the problem.

Navigate to My Documents\My Games\GratuitousSpaceBattles and look for prefs.ini
Rename it to prefs.bak and start the game.


#3

Found a fix! I did as you suggested, but instead of renaming it I edited the file. The original file read:

[prefs]
width = 1280
height = 1024
windowed = 0
sound_channels = 512

I modified it to read:

[prefs]
width = 1366
height = 768
windowed = 0
sound_channels = 512

That way the width and height matched my laptop’s screen resolution. That fixed the problem.


#4

Sw33t :slight_smile:

For anyone that doesn’t know their screen resolution settings and have the same problem.
By removing prefs.ini, GSB is forced to make a new one based on your current computers settings.

Have Fun