Nothing happens when I enter the serial code in "Profile".


#1

I’ve just re-downloaded the game unto my new computer, and when I try to enter the serial code I was sent by E-mail in the “profile/Online” -menu, nothing happens. I don’t get an error message or anything of the sort, but I can tell that I’m not logged in because the online Battle Browser-list appears empty, and I’m at Rank 0. Also, whenever I start up the game, the game is stuck on the “Refreshing User Profile” -screen until I press “Cancel”.

I bought the game while it was still in beta, and it worked fine, then.

Please help.


#2

Tried buying the game again to get a new CD-key, but it still doesn’t work.


#3

Few questions:

  • What GTB version are you using ?
  • What is your operating system / Firewall setup
  • When you entered the serial code into the game did it look something like this XXXX-XXXX-XXXX-X
  • When you Register, what user name do you use (see if i can find you online)

#4

Non-STEAM.

Windows 7 64-BIT Ultimate.

Yes. Both the old, and the new key.

“Lusketrollet”, or “Mimsy”. Can’t quite remember.


Also, there’s been another bug.

When I tried playing the first Tutorial-mission, the game speed is completely exaggerated. At least ten times faster than it’s supposed to be. The only way I can just about get it back to normal speed, is by reducing it to “0.6”, but that makes all the sounds go into “slo-mo mode”, so that really isn’t a workable condition.

My specs:

Two "NVIDIA GeForce GTX 680"s in SLI.
16GB RAM.
“Intel Core i7-3960X”.
64-BIT “Windows 7 Ultimate”.
Game runs from a standard, non-SSD-drive.


#5

In the top right corner of the GTB Title screen - what is the version number there ?

Whoa - you must have some serious hardware

Since i cant run GTB at work i will check for you when i get home
But it is indeed strange and i cant think of any reason why it would not work . .

Yeap - some serious hardware indeed.
I will have to leave this question to other forum members with comparable specs
(your PC has more power in one Graphics card that my whole computer combined)


#6

The newest version - “1.013”, as I recall.

Thanks a bunch.


#7

I can confirm that “Lusketrollet” exists but i cant find “Mimsy”.
(So on the bright side when we do get GTB online on your new PC you wont lose any medals.)

Question: Do you think you could find out if your window 7 is blocking GTB from the Internet ?
(Because that is about the only idea that i have at the moment what could explain not seeing any challanges)


#8

My firewall is disabled, if that’s what you mean.


#9

Firewall, permissions, anything.
For example is there a window in the background saying “Windows has detected a program access the internet Allow / Deny”

We know that your code works because i found your user id Lusketrollet.
However when you moved to this new computer “something” is not letting it connect when you register . .

The reason why i say something is because i do not have win7 and my knowledge on that OS is rudimentary at best - hopefully other GTB members with similar setups will respond with a better ideas then what i have come up with.


#10

I didn’t get any messages, whatsoever.

So… yeah. Apparently it’s something in my new computer that’s denying it access to the Internet, but damned if I know what it is.


#11

Hi, I have a suggestion. Check the internet connection settings for internet explorer. It doesn’t matter if you ever use IE or not, those settings for stuff like proxies control how windows base-level internet API (Wininet) work, and thus games like GTB and GSB which use WinInet are affected by them. If Internet explorer can’t surf, the game can’t connect, especially if it’s somehow set to use a proxy.
Other than that, it sounds like a security/firewall related issue.

The high-speed issue sounds like something different and unrelated, and very strange. You could launch the game windowed, then right click GTB.exe in task manager and select processor affinity to just 1 core, and see if that fixes it. It seems that somehow your PC is misreporting the amount of time that is passing, and that could, theoretically be related to is swapping GTB constantly between cores without the game knowing whose timer it is talking to.


#12

Stupid question - how do I do that? I’m not entirely sure what you mean.


#13

Hm. There’s been an update on the situation.

Like Cliffski suggested, I lowered the resolution, turned off full-screen, and set “Processor Affinity” to only one core in Task Manager. It helped. Game speed now appeared to be back to normal - at least, back to how I remember it. However, when I left the battle and turned full-screen back on, the problem was back - when I entered the Tutorial level again, everything was back to going high-speed.

After some more testing, it turned out that it didn’t matter at all how many cores the game was set to run on - it could be only one, it could be all of them - all that mattered was whether I had the game running in full-screen! Windowed, it would run at normal speed; full-screen, it would run at exaggerated speed. Right now, I’m running the game windowed, but the resolution is set to the max. As such, the game looks exactly like it’s full-screen - you can’t tell that it’s actually windowed - but that doesn’t matter, because since the computer doesn’t consider it to be in full-screen mode, the game runs just fine.

So I guess we’ve found the cause of that problem, at least.


#14

Could anyone please answer this? I still haven’t been able to find a solution.


#15

go to internet explorer, then click the cog at the top far right, then select internet options, check connections for any proxy under LAN settings.


#16

There’s a setting that says “Use a proxy server for the local Internet”, or something to that effect, and it’s NOT ticked.


#17

Hmm
You said the game worked fine in beta, but not now, and nothing in the online component of the game itself has changed. has anything else changed on your PC? any new software installed? what firewall or antivirus software are you running?


#18

Actually, the entire computer is new. I probably wasn’t clear enough on that in the initial description, but I bought the game way back when it was in beta, and it played fine from that point on.

However, I’ve just gotten a new computer - specs listed in the previous page of this thread - and now it isn’t working, any more. So, yeah, I think we’ve already established pretty clearly that it’s my computer that’s the problem, not the game. I’m just hoping we can find out what the problem is, because I miss the game.


#19

So you have tried it with the built-in windows firewall disabled, you don’t have any other firewall or internet security software installed and running?
You aren’t running the game as a ‘limited-user’ or through any sort of emulator on a mac or unde linux (just checking!).
There are no parental controls or anything similar installed that could re-direct internet traffic, and definitely no malware or spyware installed that could be doing the same thing?


#20

I have both made sure that my Firewall allows “Gratuitous Tank Battles.exe” access, and also tried running the game with the Firewall disabled altogether. I’m not entirely sure about what you mean by “Internet security software”. Like some kind of antivirus-software? If so, the answer is “no”.

I’m not running it through an emulator, and I’m using Windows 7 Ultimate 64-BIT, not a Mac or Linux. As to your question about running the game as a “limited user”, I’m not entirely sure what that means. Could you please explain?

Not that I know of.