Wierd sound issue


#1

Hello, I’ve a strange issue with GSB since I re-installed it on my new computer which is a fresh new build. During battles sounds such as the lasers “pewpews” are played only when I zoom very close to the ships but not in the most zoomed out mode, is this a new “feature” from recent patches or do I have some strange issue ? Is there a way to fix it ? I really love this game but also the laser pewpews :).


#2

Have a fiddle with your sound card acceleration settings in the windows sound control panel. There is probably some fancy ‘enhancement’ style gadgetry going on that interferes with the game.
Or you can try toggling hardware acceleration off for sound under the games options screen.


#3

I don’t seem to have any fancy enhancement and the hardware option seems useless, it’s a motherboard inbuilt card : Realtek high definition audio (so far I can see it in the peripherals manager). What kind of environment do you use for programming/running GSB ? I could perhaps find if similar issues have appeared in similar games/apps using a similar environment regarding that piece of hardware. My former PC also had a Realtek motherboard sound-card and I also had some issues which where actually solved by disabling the hardware acceleration.


#4

Isn’t this normal behavior? I’ve always thought of it as a cool feature.

I thought this was simply a function of the “sound volume” variable in various modules. I know I’ve adjusted my zoom level so that it zooms way out (1.00), and at that level I have very little “pew pew” sounds unless I zoom in further.


#5

Well the problem is there’s actually no sound, even from big cannons such as heavy plasma launchers or capital ships explosion, except the ship engines. If it’s an implemented feature, well I’ll go on and put some nice space battle music instead but the quite kitch pewpews was a thing that made GSB different imho from other space battles games.


#6

Actually yeah, now that I’ve gone back and checked, I don’t have them either even at the most zoomed in level.
I suppose it could have been a recent patch… but I’ve added a music mod too, so the lack of sounds on my machine could just be the result of something stupid I did that I haven’t look too carefully at.


#7

I do have this same thing ans i have gone in and listed my new eve-guns to be LOUD and i can not hear them at max zoon. I though it was just my pc. Maybe i’ll find my sound card and toss it back in and test it.


#8

You definitely need to replicate without any mods for it to be a bug.
The sounds do fade out as you zoom out, by design. I develop on a machine with a realtek card.


#9

so if we go and edit the files to be able to zoom out more, Then you will get to a point were you can not hear then at all?

Also the guns that i have in the even mod some are at 30 plus and i only hear then when I’m in as close as possable and they are still low. I will attempt to redo it in my unmodded version and see. I have an on-board realteck sound card, the other is a sb audigy ls pci card.


#10

loaded up the unmodifyed version of my GSB and i have the same trouble only while zommed in to the targe ship is the only think in my window do i hear gunfire. Could there be something worng in my config file?

[code[config]
CONTRAILS = 1.00
FANCYBEAMS = 1.00
DEBRIS = 1.00
TURRETS = 1.00
RUNNINGLIGHTS = 1.00
REPAIRBOTS = 1.00
ESCAPEPODS = 1.00
SHADERS = 1.00
CAMERASHAKE = 1.00
MOTIONBLUR = 1.00
HULKS = 1.00
INVERTZOOM = 0.13
PITCHSHIFT = 1.00
HARDWARESOUND = 1.00
COMMS = 1.00
RUNINBACKGROUND = 1.00
TRANSITIONS = 1.00
OPTIONS_SFX = 1.00
OPTIONS_MUSIC = 1.00
OPTIONS_MOUSESPEED = 0.25
OPTIONS_MASTERVOLUME = 1.00
OPTIONS_INTERFACE_VOLUME = 1.00
RUNINBACKGROUND = 0.00
TRANSITIONS = 1.00
OPTIONS_MINZOOM = 0.13
CHALLENGES_SHOWLOCAL = 0.00
CHALLENGES_SHOWPERSONAL = 1.00
CHALLENGES_SHOWPOSTED = 1.00
CHALLENGES_SHOWALL = 0.00
PICKER_FILTER_FIGHTER = 0.00
PICKER_FILTER_FRIGATE = 0.00
PICKER_FILTER_CRUISER = 1.00

[race]
race = federation
][/code]


#11

That all looks pretty normal to me.


#12

Doesn’t THAT mess with your sound?

I believe the ‘install’ value is “1.0”. I changed mine to “0.0” and my sound went away unless I am zoomed in dramatically.


#13

ok I reset that to 1 and see what i get. I think i edited that so i can zoom out more, but it might be the zoom in one too i can nto reambfer now.

EDIT:
That is indeed how far out you can zoom, and the only time i hear gunfire is if I’m zoomed ALL the way in, is there a way that will allow us to tweek the sound volume droppoff when we zoom out? Or is that all hard coreded into the code itself ??


#14

Same for me and no changes :

CONTRAILS = 1.00 FANCYBEAMS = 1.00 DEBRIS = 1.00 TURRETS = 1.00 RUNNINGLIGHTS = 1.00 REPAIRBOTS = 1.00 ESCAPEPODS = 1.00 SHADERS = 1.00 CAMERASHAKE = 1.00 MOTIONBLUR = 1.00 HULKS = 1.00 INVERTZOOM = 1.00 PITCHSHIFT = 1.00 HARDWARESOUND = 1.00 COMMS = 1.00 RUNINBACKGROUND = 1.00 TRANSITIONS = 1.00 OPTIONS_SFX = 1.00 OPTIONS_MUSIC = 0.00 OPTIONS_MOUSESPEED = 0.50 OPTIONS_MASTERVOLUME = 1.00 OPTIONS_INTERFACE_VOLUME = 1.00 RUNINBACKGROUND = 0.00 TRANSITIONS = 1.00 OPTIONS_MINZOOM = 1.00 CHALLENGES_SHOWLOCAL = 0.00 CHALLENGES_SHOWPERSONAL = 0.00 CHALLENGES_SHOWPOSTED = 0.00 CHALLENGES_SHOWALL = 1.00


#15

I appear to be having the same issue. My version is unmodified, save for the expansions, and updated to 1.47. Fiddling with the volume settings appeared to do nothing to increase the weapons and explosion sounds, which are now only audible zoomed all the way in (previously, I could here them clearly at the default zoom level, and they were just louder closer in). I’m using a Soundblaster X-Fi soundcard.

Config file:

[config]
CONTRAILS = 1.00
FANCYBEAMS = 1.00
DEBRIS = 1.00
TURRETS = 1.00
RUNNINGLIGHTS = 1.00
REPAIRBOTS = 1.00
ESCAPEPODS = 1.00
SHADERS = 1.00
CAMERASHAKE = 1.00
MOTIONBLUR = 1.00
HULKS = 1.00
INVERTZOOM = 1.00
PITCHSHIFT = 1.00
HARDWARESOUND = 1.00
COMMS = 1.00
RUNINBACKGROUND = 1.00
TRANSITIONS = 1.00
OPTIONS_SFX = 1.00
OPTIONS_MUSIC = 0.50
OPTIONS_MOUSESPEED = 0.50
OPTIONS_MASTERVOLUME = 0.99
OPTIONS_INTERFACE_VOLUME = 1.00
RUNINBACKGROUND = 0.00
TRANSITIONS = 1.00
CHALLENGES_SHOWLOCAL = 0.00
CHALLENGES_SHOWPERSONAL = 0.00
CHALLENGES_SHOWPOSTED = 0.00
CHALLENGES_SHOWALL = 1.00
OPTIONS_MINZOOM = 1.00
PICKER_FILTER_FIGHTER = 1.00
PICKER_FILTER_FRIGATE = 0.00
PICKER_FILTER_CRUISER = 1.00

[race]
race = federation

Edit: I didn’t have this problem the last time I played in anger (which was, sadly, about the time Tribe came out), so it’s clearly something more recent. Something in the recent expansions/patches changing the volume at zoom level maybe?


#16

I’m going to dig up this tread, but it seems the whole problem is gone since I’ve updated my graphic card drivers. (NVIDIA gtx460)