New patch available (1.23)


#41

Thanks, that worked :blush:


#42

Is there going to be a patch from version 1.0 to the latest version?


#43

No sorry, if you have 1.0, you will need to just re-downlaod the whole game using the original link.


#44

But you sell CDs with version 1 of the game on them? Perhaps you should stop if they can’t be patched to the latest version.


#45

I don’t sell any CDs of Democracy 2. What do you mean?


#46

When we go to buy the game, it offers a cd of the game for 10 dollars more. I believe that’s what the previous poster was refering.


#47

Yes. I ordered and received a CD of Democracy 2 and as I understand it if I ever want to use it to install the game and then patch it up to the latest version then that isn’t possible.


#48

Oh I didn’t realise the CD thing was enabled by default. I see what you mean, but since practically every file has changed since the first version a patch would be not that much smaller than a full re-download in any case.


#49

The CD thing isn’t enabled by default. I ordered it on the basis that I would be able to use it. I have to say I’ve never ordered another game CD only to find it useless. Not a mistake I will make again.


#50

Its not useless, but really, there is no difference. I can make a patch available, and that patch will just be the full game. if you are concerned about needing to patch the game to the latest version, there is no need to be, I always ensure anyone who ever purchased the game can always get the very latest version without grief.
I can understand people on 56k being wary of re-downloading a whole game again, but in the case of 1.0 -> latest, enough has changed to mean there is little difference :frowning:


#51

Version 1.07 is out now. for people already on 1.06 there is a patch. Alternatively you can redownload the whole thing again.
here are the changes:

And here is the patch for people on 1.06:
positech.co.uk/democracy2/De … tch107.exe


#52

Unable to access BMT site for patching for past two weeks. Frequent and repeated problem.


#53

Hi,

I am having problems with the new mod breakdown thing - when I click an event, the window shows up fine, but when I click the “output” tab, it always changes to a different event, and then yet another one when I click the “input” tab. That window will then not close down. When I start pressing escape, things start going even more mad, with random events showing up. I’m getting slightly different problems on the other screens (situations, etc)., with nothing happening when I click the “output” tab then it changing to a different situation when I click the input tab. It looks like it will be very useful, but unfortunately seems to be all messed up at the moment.

I’m also confused by the figures that I do see. For example, religious condemnation is coming out very high, even though my religious folk are reasonably happy. When I click to go “in detail”, it says +0.8000 for religious, despite the formula being 0.8-(0.7*x), which should mean that it would come out at less than 0.8, as my religious happiness is certainly not at zero. This only seems to affect the religious happiness from what I’ve seen so far.

Also, why, if I have rail subsidies at full (1.0), does it only deduct 0.3 something from rail strikes, when the formula is RailSubsidies,0-(0.5*x)? See screenshot - thomashughes.co.uk/democracy/railstrikes.JPG


#54

Yet another bug. (Sorry cliff!!)
Playing Koan. I got a screen saying “assasination” then … underneith it. Then nothing. Couldn’t exit normaly had to quit the game. Is this normal if you get killed?


#55

Eeeek. I thought this was the exact bug that I have just fixed. Are you getting normal assassination messages at any point?


#56

Yes, just played the same scenario twice, lost the election both times. But i did get a normal “failed assasination”. Oh and a gentle reminder, any luck with taxing prostitution and a tax on gambling? As it stands i tend to cancel my policy on gambling because it costs me money, and well i’d love to leave it and tax it. Also what about taxing drugs if you legalize them? Sorry to be such a pain in the ass about it .


#57

You aren’t being a pain up the ass at all, its because of people like the posters on this forum that the game gets these improvements. You can’t imagine how much my brain glazes over staring at this stuff all day for so long, its excellent to get fresh perspective on everything, and its extremely welcome.

I do intend to get stuff like taxation of those policies in. AFAIK this is moddable right now, I just haven’t tried it because my #1 priority is to ensure that we have a really stable, solid and as bug-free as possible game, and then we can all go to town with new missions, new policies and other mods and tweaks.
Once I have a version thats gone a few weeks without any major bug reports, I’m going to get working on stuff like that.


#58

I also had this problem, playing a mission of my own creation. The second time this happened, I pressed escape and then received a proper message telling me that I had been assassinated and allowing me to return to the main menu.

Oh, and I started a new mission and was told immediantely, before I had even taken a turn, that the debt ceiling had been reached. I’ve played this mission quite a few times now and it does not (normally) start anywhere near the debt ceiling.

P.S. Cliff, any progress on the problem I reported above. Especially with religious happiness - this seems to be read at the wrong value when events and dilemmas are chosen.


#59

is it actually seeming to be the wrong value, or does it just look like its being displayed wrong in that debug stuff?


#60

Ahahahaha

I know what it is.
I think I can just fix the data and leave the exe.

Basically voter group values are not 0 to 1.0
they are -1.0 to +1.0
This is different to democracy 1 as i recall.
So stuff that uses them as an input needs to be aware of this…