Steam version and installer update [1.24]


#1

Hi,

I just bought the game today on Steam. When I first launched it it was version 1.23 and it still is right now. But something happened the second time I launched it (I had quit the game and closed Steam itself, then re-started Steam and re-launched the game), that second launch had a “download process” blue bar on-screen before the main menu appeared, and then I was automatically sent back to the Desktop with the official GSB patch 1.24 installer screen open. It wanted to install the update under the default retail (or perhaps I should say non-Steam) installation path, namely under the usual Program Files folder (followed by the game name, etc).

Instead I refused to update and canceled it because I think that Steam games need specific updates and they aren’t usually compatible with official updates from installers like all non-Steam patches are. I wanted to point at this to the GSB team, that they perhaps should be aware that the Steam version tries to update like the non-Steam version and that it might not be a good thing to do. At least even if I refused to update I was still able to launch the game afterwards and it remained version 1.23. So I thought that posting this might help the team figure out about a way to update the Steam version properly. If in fact it was alright and I could have updated then please let me know.

Thanks.


#2

I don’t think steam has the 1.24 update quite yet. Just be patient, I am sure Cliffski is on it.

EDIT: YAY! 100 Posts! And i got this in a week.


#3

Indeed that’s what I thought. I was just pointing at the fact that the game still tries to update itself “normally” and that it shouldn’t be so for the Steam version, at least I think, since as I said from what I do know of Steam all games running from it need very specific Steam-compatible patches that have gone through a testing process at Valve before the Steam version of any games are updated.


#4

Just because its different doesn’t mean its wrong… you said it ‘attempted to update’- did it actually update?


#5

No the game was not updated per se, what it did was to simply download the patch itself (the installer), which explains the download process I saw before the main menu appeared (it just download the patch) and then I was automatically sent back to the Desktop with the patch’s installer open and ready to install the patch to a default Program Files » Gratuitous Space Battles folder. I canceled it because I have never updated any of my games on Steam via a separate installer like all “retail” and non-Steam games do.


#6

I would go ahead and let it run its course- it’s not like its pulling some random evil file off of a dark corner of the internet.

Not ALL games NEED the Steam interface to run- in fact, you can put any game or program shortcut into Steam that you want.


#7

I wasn’t thinking about evil files mind you hehe, just compatibility issues (potentially I mean). But since the game is small (around 300MB) I think I will try it and see if it works that way, if it screws up something then I’ll just re-download it. I’ll post later to let everyone know if it worked or not.

EDIT: Ok, so far it seems to be working fine. So I started the patch’s installer again and I changed the default patch’s installation path from the usual Program Files folder to the one in which the Steam version is installed (in the common folder within the steamapps one). Then the patching process went on without issues. Then I launched the game and the main menu is properly displaying the version as being 1.24. All I have left to do is to make sure that all the changes from the patch were indeed properly applied in the game. But for now it seems to be working.


#8

I bought the Steam version as well, and had the same concerns… having read your post, I’d like to go ahead and try it myself but I don’t know where it downloaded the patch. It doesn’t seem to be in the game directory, does anyone happen to know where it downloaded it to?

Never mind, found it… \MyDocuments\MyGames\Patches

At first blush, it looks like when I click the “Online” config button after the patch, it crashes. Haven’t had a chance to try anything else yet. Nope… worked OK the second time, could’ve just been an unrelated crash. However, it does still say 1.23 in the game.


#9

I haven’t spoken to steam about patches yet. And everyone buying the steam copy gets 1.23 right now.
There shouldn’t be a problem updating using the built-in patcher. If there is any sort of testing for patches by steam, that’s bound to put things back a bit, so if you want the latest version you might as well just let the auto-patcher do it’s thing.
Make sure it installs to the right folder though. The patcher is currently ‘dumb’ and doesn’t know where you installed the game, so ensure it finds the right place.
I strongly recommend patch 1.24, it fixes laggy mouse and a few other things.


#10

Thanks for coming here and replying :slight_smile:

I tried the installer as I mentioned in the edited part of my previous post, and I have tested and it works, nothing crashes, nothing freezes and what was changed in 1.24 has been applied properly over 1.23 without any issues (from what I’ve seen anyway) including the new (Windows default) cursor indeed, so at least in the specific case of Gratuitous Space Battles it looks like Valve won’t have to temper with anything and won’t have to create Steam-compatible patches, which is certainly a good thing (in my opinion).


#11

it may work just now, but at some random point in time steam is going to notice that the .exe file, at least, doesn’t match its hash, delete it, and redownload it (or possibly EVERY changed file)
steam is quite good about new files, but changed files… not so much. This has caused issues with modding in a couple of games that don’t have a “clean” modding system


#12

Hello all. And thanks for great game just bought it from steam yesterday and loving it, but even all tips in this topic i cant get my game updated to 1.24.

When i go manualy update it and set the path for C:\Users(My name)\Documents\My Games\GratuitousSpaceBattles. it gives me GSB.exe part could not be found error and tells me fmodex.dll could not be found. I tryed uninstall game like 4 time and allways get the error. So im stuck at 1.23.

So any more tips or did i make mistake somewhere? Any help could be great.

(Edit) And i allready lost all my unlocked ship things when i deleted all files when i try get
patch to work. Should i wait for 1.24 patch b4 i try unlock them agen or can i get this patch work if i keep all the unlock files save?

PS. Any news when Steam start to update this great game normaly?


#13

I am having the exact same problem as the above poster.

When the update application tries to get the game to 1.24 it tells me there some sort of .exe error. Since not many people have this problem Im assuming its a steam compatibility issue, as steam is still stuck at 1.23. Trying to move the patch to the steam directory and reinstalling also fail to allow the patch to be installed.

I hope that you are able to contact steam and work out the update conflicts. Thanks.

I woudlve bought retail if there was a nearby store. Steam is a pain in the ass :/.


#14

The patch does not know where the game is installed, so you have to tell it where steam has installed it

So if you installed to the wrong place, (which is what those errors are a symptom of) then you need to re-run the patch. The gam,e downlaods and stores any patches here:

\MyDocuments\My Games\Gratuitous Space Battles\patches

Just re-run that.


#15

Still get the same error. I tryed instal the patch every folder in MyDocuments\My Games\Gratuitous Space Battles\. Each time at end of patch install it gives the error. Any other tips to get patch 1.24?

The manual patch file is GSBBeta124.exe right? What can be found at MyDocuments\My Games\Gratuitous Space Battles\ folder right? And i should set the install for that folder too?

Thanks for help


#16

Got my hands on normal install of this game and i see there is diffirent files in Steam version than in normal. So no wonder patch thingie dont work. Patcher is trying find files what in steam folder dont have. It seems i need to use my Steam version key in normal none-steam version to play 1.24. Untill Steam get its 1.24 version.


#17

I just patched the steam game last night with the patch in the my games folder.

You have to choose the folder steam/steamapps/common/gratuitousspacebattles


#18

Thanks my white knight! Ohh i thought game was at other place. But thanks for info you saved the day. Odd it didnt show in my file search earlier. But im one happy space captain now.

(Edit) My mouse finaly not drunk. So great!


#19

Cliffski and graydon, thanks for the quick replies, but Ive tried that already. I find the patch program and click run, and then it prompts me to save it somwhere. So I save it to the steam folder, and let it run, but at the end it still tells me I get a .exe error or some kind.

Im saving to the steam/common/GSB folder.


#20

Just make sure it go for steam/common/GSB folder. At least for me if i go to set that bath it tryed make new folder like steam/common/GSB folder/GSB folder agen. Not sure if it means anything bad but i just manualy deleted extra GSB folder what it gived when i choose the path by clicking the icons